File: README

package info (click to toggle)
openclonk 5.5.1-2
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 95,984 kB
  • ctags: 30,251
  • sloc: cpp: 156,513; ansic: 63,819; xml: 31,289; python: 1,090; php: 767; makefile: 138; ruby: 27; sh: 22
file content (54 lines) | stat: -rwxr-xr-x 2,512 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
Requirements
============
You should be able to build OpenClonk with any C++ compiler that supports
ISO C++11. That said, on Windows, we recommend using Microsoft Visual C++
2010 or higher; the Express edition will be sufficient. On Linux, you will
be fine with GNU g++ 4.6 or later. Apple users should use a clang-based
XCode version.

To generate project files for your chosen build system, you will also have to
install CMake from http://www.cmake.org/.

Additionally, OpenClonk depends on a number of third-party libraries:
  - zlib (http://zlib.net/)
  - libpng (http://www.libpng.org/pub/png/libpng.html)
  - libjpeg-turbo (http://sourceforge.net/projects/libjpeg-turbo/files/)
  - FreeType (http://www.freetype.org/)
  - The OpenGL Extension Wrangler Library (http://glew.sourceforge.net/)
  - FreeALUT (https://github.com/vancegroup/freealut)
  - libogg and libvorbis (https://www.xiph.org/downloads/)
  - Boost (http://www.boost.org/users/download/)

OS X Specific
=============
OpenClonk supports OS X versions 10.6 "Snow Leopard" and later. You can build
universal binaries by setting CMAKE_OSX_ARCHITECTURES to "x86_64 i386", but
you will of course need universal versions of the dependencies in that case.
If you are using brew (https://github.com/mxcl/homebrew) or MacPorts
(http://www.macports.org/), the packages you'll have to install are:
    libjpeg, libpng, freetype, glew, libogg, libvorbis, boost

Linux Specific
==============
For building OpenClonk on Linux, you need the following libraries in addition
to the ones listed above:
  - GTK+ 2.0 or 3.0 (http://www.gtk.org)
  - libGL (http://www.mesa3d.org/)
  - SDL 1.2 (http://www.libsdl.org/download-1.2.php)
  - SDL_mixer 1.2 (http://www.libsdl.org/projects/SDL_mixer/release-1.2.html)
  - libupnp
  - libxrandr
Most distributions should provide these dependencies via their packaging
system. For Debian based distributions, you will need these packages:
  build-essential cmake imagemagick libboost-dev libboost-regex-dev
  libfreetype6-dev libgl1-mesa-dev libglew-dev libgtk2.0-dev libjpeg-dev
  libpng-dev libsdl1.2-dev libsdl-mixer1.2-dev libupnp-dev libxrandr-dev
  x11proto-core-dev zlib1g-dev

Windows Specific
================
In addition to the libraries above, you will need one more if you want to
target Windows:
  - OpenAL Soft (http://kcat.strangesoft.net/openal.html)
To create an installer, you will also need the Nullsoft Install System
(http://nsis.sourceforge.net/). To create the installer, build the "setup" target.