1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
%:
dh $@ --buildsystem=cmake -Bbuild
CONFIG_ARGS := -DWITH_AUTOMATIC_UPDATE=0
ifeq (arm,$(shell dpkg-architecture -q DEB_HOST_ARCH_CPU))
CONFIG_ARGS += -DQt5Widgets_FOUND=off
endif
override_dh_auto_configure:
ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
dpkg-architecture -a$(DEB_BUILD_ARCH) -f -c dh_auto_configure --builddirectory=build-native -- -DHEADLESS_ONLY=ON
dpkg-architecture -a$(DEB_BUILD_ARCH) -f -c dh_auto_build --builddirectory=build-native -- c4group
dh_auto_configure -- $(CONFIG_ARGS) -DIMPORT_NATIVE_TOOLS=../build-native/NativeToolsExport.cmake
else
dh_auto_configure -- $(CONFIG_ARGS)
endif
override_dh_strip:
dh_strip --dbgsym-migration='openclonk-dbg (<< 8.0-1~)'
override_dh_builddeb:
dh_builddeb
|