1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58
|
# HG changeset patch
# User enevill
# Date 1521985117 -3600
# Sun Mar 25 14:38:37 2018 +0100
# Node ID 7d1ae835ef5194e7ae5b56b51f944029fe602d11
# Parent 1b1de4b263c81853719f6bb0385fe23bc4e35f6c
8199138: Add RISC-V support to Zero
Reviewed-by: aph, erikj, ehelin, ihse
@@ -28,6 +28,13 @@
# autoconf system (which might easily get lost in a future update), we wrap it
# and fix the broken property, if needed.
+machine=`(uname -m) 2>/dev/null` || UNAME_MACHINE=unknown
+if test $machine = riscv64; then
+ # This is all we need to know for riscv64
+ echo riscv64-unknown-linux-gnu
+ exit
+fi
+
DIR=`dirname $0`
OUT=`. $DIR/autoconf-config.guess 2> /dev/null`
@@ -40,8 +40,8 @@
exit
fi
-# First, filter out everything that doesn't begin with "aarch64-"
-if ! echo $* | grep '^aarch64-' >/dev/null ; then
+# First, filter out everything that doesn't begin with "aarch64-" or "riscv64-"
+if ! echo $* | grep '^aarch64-\|^riscv64-' >/dev/null ; then
. $DIR/autoconf-config.sub "$@"
# autoconf-config.sub exits, so we never reach here, but just in
# case we do:
@@ -56,6 +56,10 @@
config=`echo $1 | sed 's/^aarch64-/arm-/'`
sub_args="$sub_args $config"
shift; ;;
+ riscv64-* )
+ config=`echo $1 | sed 's/^riscv64-/x86-/'`
+ sub_args="$sub_args $config"
+ shift; ;;
- ) # Use stdin as input.
sub_args="$sub_args $1"
shift; break ;;
@@ -68,7 +72,7 @@
result=`. $DIR/autoconf-config.sub $sub_args "$@"`
exitcode=$?
-result=`echo $result | sed "s/^arm-/aarch64-/"`
+result=`echo $result | sed "s/^arm-/aarch64-/" | sed "s/^x86-/riscv64-/"`
echo $result
exit $exitcode
|