1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
|
Description: Use IP address in tests
Ubuntu build machines are not set up for dns. Use IP addresses to get correct test
outcomes.
Author: Vladimir Petko <vladimir.petko@canonical.com>
Forwarded: not-needed
Last-Update: 2023-03-27
@@ -13,7 +13,7 @@
public static void main(String[] args) {
try {
InetAddress addr = InetAddress.getByName("localhost");
- InetAddress remoteAddr = InetAddress.getByName("bugs.openjdk.java.net");
+ InetAddress remoteAddr = InetAddress.getByName("8.8.8.8");
if (!addr.isReachable(10000))
throw new RuntimeException("Localhost should always be reachable");
NetworkInterface inf = NetworkInterface.getByInetAddress(addr);
@@ -39,7 +39,7 @@
SharedSecrets.getJavaNetInetAddressAccess();
public static void main(String[] args) throws Exception {
- final String HOST = "dummyserver.java.net";
+ final String HOST = "localhost";
InetAddress ia = null;
ia = InetAddress.getByName(HOST);
testInetAddress(ia, HOST);
|