1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
|
Description: print warning to install openjdk-*-jre package
fontmanager support was moved to recommends, warn user to
either install -jre package or recommended packages.
Forwarding is not needed as this is a Debian-only issue.
Author: Vladimir Petko <vladimir.petko@canonical.com>
Forwarded: not-needed
@@ -52,7 +52,13 @@ public class FontManagerNativeLibrary {
shared library in order to avoid dependency. */
System.loadLibrary("freetype");
}
- System.loadLibrary("fontmanager");
+
+ try {
+ System.loadLibrary("fontmanager");
+ } catch (Throwable t) {
+ System.err.println("Please install the openjdk-*-jre package or recommended packages for openjdk-*-jre-headless.");
+ throw t;
+ }
}
/*
|