1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- --disable-silent-rules
include /usr/share/dpkg/default.mk
VER_FULL = $(DEB_VERSION_UPSTREAM)
properties.html:
wget -O $@ http://openslide.org/docs/properties/
aperio.html:
wget -O $@ http://openslide.org/formats/aperio/
hamamatsu.html:
wget -O $@ http://openslide.org/formats/hamamatsu/
leica.html:
wget -O $@ http://openslide.org/formats/leica/
mirax.html:
wget -O $@ http://openslide.org/formats/mirax/
philips.html:
wget -O $@ http://openslide.org/formats/philips/
sakura.html:
wget -O $@ http://openslide.org/formats/sakura/
trestle.html:
wget -O $@ http://openslide.org/formats/trestle/
ventana.html:
wget -O $@ http://openslide.org/formats/ventana/
generic-tiff.html:
wget -O $@ http://openslide.org/formats/generic-tiff/
%.xml: %.html
xsltproc --nonet --output $<.dummy.xml --html debian/process.xsl $<
sed -i -e 's/BEGIN SECTION/<refsection>/g' -e 's@END SECTION@</refsection>@g' $<.dummy.xml
xmllint --nonet --output $@ --format $<.dummy.xml
rm $<.dummy.xml
debian/openslide-formats.3: properties.xml aperio.xml hamamatsu.xml leica.xml mirax.xml philips.xml sakura.xml trestle.xml ventana.xml generic-tiff.xml debian/openslide-formats.3.xml
(cd debian && sed -e 's@VER_FULL@$(VER_FULL)@g' openslide-formats.3.xml > openslide.tmp.xml)
(cd debian && xsltproc --xinclude openslide.tmp.xml)
override_dh_install:
dh_install
find debian/tmp -name lib*.la -delete
|