1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56
|
Description: adjust upstream Makefile to Debian
As of 1.3.2, upstream Makefile relies on the container built according to
https://github.com/open-telemetry/build-tools/blob/10a409a16331d2b65dda71056096e79410be5538/protobuf/Dockerfile
See also:
https://github.com/open-telemetry/opentelemetry-proto/issues/142
.
So the main change of this patch is to replace the docker-based stuff with
build dependencies.
.
A second change includes removing gen-* targets for which there are not
packaged build dependencies, such as protoc plugins, or that we don't
(currently) support.
.
And third, only the cpp and python code is generated, for the mommen.
Forwarded: not-needed
Author: Santiago Ruano Rincón <santiago@freexian.com>
@@ -14,17 +14,14 @@ $(1)
endef
.PHONY: all
-all: gen-all markdown-link-check markdownlint
+all: gen-all
# Generate all implementations
.PHONY: gen-all
-gen-all: gen-cpp gen-csharp gen-go gen-java gen-kotlin gen-objc gen-openapi gen-php gen-python gen-ruby
+gen-all: gen-cpp gen-python
-OTEL_DOCKER_PROTOBUF ?= otel/build-protobuf:0.9.0
-BUF_DOCKER ?= bufbuild/buf:1.7.0
-PROTOC := docker run --rm -u ${shell id -u} -v${PWD}:${PWD} -w${PWD} ${OTEL_DOCKER_PROTOBUF} --proto_path=${PWD}
-BUF := docker run --rm -v "${PWD}:/workspace" -w /workspace ${BUF_DOCKER}
+PROTOC := /usr/bin/protoc
# When checking for protobuf breaking changes, check against the latest release tag
LAST_RELEASE_TAG := $(shell git tag --sort=committerdate | tail -1)
# Options are described in https://docs.buf.build/breaking/usage#git
@@ -42,12 +39,6 @@ PROTO_GEN_PHP_DIR ?= $(GENDIR)/php
PROTO_GEN_PYTHON_DIR ?= $(GENDIR)/python
PROTO_GEN_RUBY_DIR ?= $(GENDIR)/ruby
-# Docker pull image.
-.PHONY: docker-pull
-docker-pull:
- docker pull $(OTEL_DOCKER_PROTOBUF)
- docker pull $(BUF_DOCKER)
-
# Generate gRPC/Protobuf implementation for C++.
.PHONY: gen-cpp
gen-cpp:
|