1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
|
export DEB_CFLAGS_MAINT_APPEND = -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -fdebug-prefix-map=$(CURDIR)=/
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export DEB_OBJCFLAGS_MAINT_APPEND = -std=gnu11
%:
dh $@ --with autoreconf
override_dh_auto_configure:
dh_auto_configure -- --prefix=/usr --with-openvpn=/usr/include/openvpn
override_dh_auto_clean:
rm -f tests/Makefile
dh_auto_clean
override_dh_auto_install:
dh_auto_install -- prefix=/usr libdir=/usr/lib/openvpn
|