File: changelog

package info (click to toggle)
openyahtzee 1.9.3-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 1,044 kB
  • sloc: sh: 4,702; cpp: 2,231; makefile: 60
file content (133 lines) | stat: -rw-r--r-- 4,487 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
openyahtzee (1.9.3-4) unstable; urgency=medium

  * Source-only upload to enable migration to testing.
  * Switch to debhelper-compat = 12.
  * Declare compliance with Debian Policy 4.4.0.

 -- Markus Koschany <apo@debian.org>  Sun, 04 Aug 2019 10:48:57 +0200

openyahtzee (1.9.3-3) unstable; urgency=medium

  * Team upload.
  * Build against GTK 3 variant of wxWidget library. Replaced build dependency
    libwxgtk3.0-dev by libwxgtk3.0-gtk3-dev. (Closes: #933420)

 -- Bruno Kleinert <fuddl@debian.org>  Sat, 03 Aug 2019 08:02:48 +0200

openyahtzee (1.9.3-2) unstable; urgency=medium

  * Switch to compat level 11.
  * Use canonical VCS URI.
  * Declare compliance with Debian Policy 4.2.1.
  * Drop deprecated menu file.
  * Remove get-orig-source target.
  * Use https for Format field.

 -- Markus Koschany <apo@debian.org>  Fri, 07 Dec 2018 21:21:26 +0100

openyahtzee (1.9.3-1) unstable; urgency=medium

  * Imported Upstream version 1.9.3.
  * Vcs-Browser: Use https.
  * Update my e-mail address.
  * Update debian/watch to detect new releases.
  * Add get-orig-source target.
  * Drop all patches. Applied upstream.
  * wrap-and-sort -sa.
  * Update copyright years.

 -- Markus Koschany <apo@debian.org>  Sat, 09 Jan 2016 18:32:24 +0100

openyahtzee (1.9.2-1) unstable; urgency=medium

  * Imported Upstream version 1.9.2.
  * Drop wx3.0-compat.patch. Merged upstream.
  * Add wxstrtol.patch to fix a FTBFS. Thanks to Guy Rutenberg for the patch.
  * Update copyright years.
  * Declare compliance with Debian Policy 3.9.6.
  * Update VCS browser field to new canonical address.
  * Add keywords.patch and add keywords to desktop file.

 -- Markus Koschany <apo@gambaru.de>  Wed, 29 Apr 2015 11:47:22 +0200

openyahtzee (1.9.1-2.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Update wx3.0-compat.patch to fix use of undefined values when calculating
    totals. (Closes: #750729)

 -- Olly Betts <olly@survex.com>  Fri, 06 Jun 2014 22:44:48 +1200

openyahtzee (1.9.1-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Update to use wxwidgets3.0 (new patch wx3.0-compat.patch)
    (Closes: #749992)

 -- Olly Betts <olly@survex.com>  Sun, 01 Jun 2014 00:31:01 +1200

openyahtzee (1.9.1-2) unstable; urgency=low

  * New Maintainer. (Closes: #544935)
  * debian/control:
    - Change Priority from extra to optional.
    - New Standards-Version 3.9.4, no changes needed.
    - Update Vcs-fields. Now Open Yahtzee is maintained in a git repository.
  * Update debian/copyright to copyright format 1.0.
  * debian/rules:
    - Build with hardening=+all.
    - Build with --as-needed to avoid unnecessary dependencies.
    - Remove autotools_dev addon because autoreconf does the job just as well.
  * Bump compat level to 9 and require debhelper (>=9) to use automatic
    hardening build flags.

 -- Markus Koschany <apo@gambaru.de>  Thu, 09 Nov 2012 21:04:16 +0100

openyahtzee (1.9.1-1) unstable; urgency=low

  * Team upload.
  * New upstream release
    - Drop patches, all obsolete or merged
    - Doesn't use sqlite any more, drop that
    - Manual page merged, drop Debian one
    - Freedesktop menu file merged, drop Debian one
    - Now requires boost, add to build-deps
    - Uses a macro from autoconf-archive, add to build-deps
  * Run wrap-and-sort again
  * Bump Standards-Version, no changes needed

 -- Paul Wise <pabs@debian.org>  Sat, 25 Feb 2012 16:56:45 +0800

openyahtzee (1.9-1) unstable; urgency=low

  * Team upload.

  [ Barry deFreese ]
  * Update package description. (Closes: #504432).

  [ Paul Wise ]
  * New upstream release
    - Remove new embedded code copy of sqlite3
  * Wrap build-deps one per line
  * Add ${misc:Depends} to dependencies just in case
  * Fix the watch file to find latest release
  * Correct the Homepage link
  * Drop unneeded comments from the manual page
  * Switch to dpkg-source v3
  * Add a patch to fix FTBFS with new GCC (Closes: #565080)
  * Update copyright information & refer to the correct GPL version
  * Switch to debhelper 7 & dh
  * Bump Standards-Version, no changes needed
  * Install an XPM icon for the Debian menu entry
  * Improve the Debian menu file
  * Improve the freedesktop menu file

 -- Paul Wise <pabs@debian.org>  Fri, 01 Apr 2011 22:31:41 +0800

openyahtzee (1.8.1-1) unstable; urgency=low

  [ Barry deFreese ]
  * Initial Release (Closes: #405825)
    + Using Zak B. Eleps packaging work

 -- Barry deFreese <bdefreese@debian.org>  Sat, 27 Sep 2008 22:22:28 -0400