1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
|
DOC_TMP_FILES := doc/org.aux doc/org.cp doc/org.cps doc/org.fn \
doc/org.fns doc/org.ky doc/org.kys \
doc/org.log doc/org.pg doc/org.toc doc/org.tp \
DOC_FILES := doc/*pdf
clean:
dh_testdir
dh_testroot
dh_clean
rm -f $(DOC_FILES) $(DOC_TMP_FILES)
build build-indep build-arch:
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
cp lisp/* $(CURDIR)/debian/org-mode/usr/share/emacs/site-lisp/org-mode
cp -r etc $(CURDIR)/debian/org-mode/usr/share/emacs/site-lisp/org-mode
cp -r contrib $(CURDIR)/debian/org-mode/usr/share/org-mode/
rm -f $(DOC_TMP_FILES)
find $(CURDIR)/debian/org-mode/usr/share/org-mode/ -type f -exec chmod 644 "{}" \;
find $(CURDIR)/debian/org-mode/usr/share/emacs/site-lisp/org-mode -type f -exec chmod 644 "{}" \;
find $(CURDIR)/debian/org-mode/usr/share/org-mode/ -name .DS_Store -exec rm -f "{}" \;
find $(CURDIR)/debian/org-mode/usr/share/org-mode/ -name .gitignore -exec rm -f "{}" \;
binary-indep: install
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs
dh_link
rm -f $(CURDIR)/debian/org-mode/usr/share/doc/org-mode/*texi*
dh_installemacsen -v
dh_fixperms
dh_compress
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
binary-arch: build-arch
binary: binary-indep binary-arch
.PHONY: build clean build-indep build-arch binary binary-indep binary-arch
|