1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
|
include /usr/share/dpkg/pkg-info.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@ --with autoreconf
override_dh_clean:
dh_clean
$(RM) .tarball-version
$(RM) .version
$(RM) src/tests/package.m4
$(RM) src/tests/testsuite
override_dh_autoreconf:
echo $(DEB_VERSION_UPSTREAM) > .tarball-version
dh_autoreconf
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
override_dh_installsystemd:
dh_installsystemd --no-enable --no-start
|