1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
override_dh_auto_configure:
dh_auto_configure --verbose -- \
--disable-silent-rules \
--with-trust-paths=/etc/ssl/certs/ca-certificates.crt \
--with-hash-impl=internal --enable-doc
override_dh_makeshlibs:
dh_makeshlibs \
-Xusr/lib/$(DEB_HOST_MULTIARCH)/pkcs11/p11-kit-trust.so -- -c4
override_dh_strip:
dh_strip --ddeb-migration='libp11-kit0-dbg (<< 0.23.2-3~)'
override_dh_link:
rm -rf debian/libp11-kit0-dbg/usr/share/doc/libp11-kit0-dbg \
debian/p11-kit-modules/usr/share/doc/p11-kit-modules
dh_link
%:
dh $@ --with autoreconf
|