1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND=-Wl,-z,defs
export DEB_LDFLAGS_MAINT_APPEND+=-Wl,--as-needed
%:
dh $@ --parallel --with autoreconf,systemd
override_dh_autoreconf:
dh_autoreconf --as-needed autoreconf -- -vif -Wno-portability
override_dh_auto_configure:
dh_auto_configure -- --disable-static \
--disable-tests \
--with-brand=clusterlabs \
--with-configdir=/etc/default \
--libexecdir=/usr/lib
override_dh_auto_build-indep:
dh_auto_build
$(MAKE) doxygen
rm doc/api/html/*.md5
override_dh_auto_test:
empty_dir = debian/tmp/usr/share/doc/pacemaker/Pacemaker_Development/desktop/en-US/images
override_dh_install:
rm -r debian/tmp/usr/lib/*/lib*.la \
debian/tmp/usr/share/doc/pacemaker/COPYING \
debian/tmp/usr/share/doc/pacemaker/README.markdown \
debian/tmp/usr/share/doc/pacemaker/licenses
if [ -d "$(empty_dir)" ]; then \
rm $(empty_dir)/.keep; \
rmdir $(empty_dir); \
fi
dh_install --fail-missing
debian/check_header_deps pacemaker
override_dh_installdocs:
dh_installdocs -A README.markdown
override_dh_installchangelogs:
dh_installchangelogs ChangeLog
override_dh_installinit:
dh_installinit -p pacemaker --onlyscripts
dh_installinit -p pacemaker-remote --onlyscripts --name=pacemaker_remote
dh_installinit --remaining-packages
override_dh_strip:
dh_strip --dbgsym-migration=pacemaker-dbg
.DELETE_ON_ERROR:
DESC_SUBST=debian/description.subst
$(DESC_SUBST): debian/description
tr '\n' _ < $< | sed 's/^/DESCRIPTION=/;s/_/$${Newline}/g' >$@
override_dh_gencontrol: $(DESC_SUBST)
debian/check_header_deps
dh_gencontrol -- -T$<
override_dh_auto_clean:
dh_auto_clean
rm -rf doc/api
override_dh_clean:
dh_clean $(DESC_SUBST)
|