1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
|
Description: Tune plugin files for Debian
* Fix paths so they match the package's installation paths.
* Avoid duplicate files.
* Don't depend on bash.
* Adapt the documentation.
Author: Matteo Cypriani <mcy@lm7.fr>
Origin: vendor
Forwarded: not-needed
Last-Update: 2016-11-24
@@ -2,13 +2,13 @@
Type=Service
ServiceTypes=KonqPopupMenu/Plugin
MimeType=audio/*;video/*;application/x-flash-video;inode/directory
-Icon=/etc/pacpl/icon.png
+Icon=pacpl
Actions=PACPL-Convert
X-KDE-StartupNotify=false
X-KDE-Priority=TopLevel
[Desktop Action PACPL-Convert]
Name=Perl Audio Converter
-Icon=/etc/pacpl/pacpl.png
-Exec=/usr/bin/PACPL-Konvert %F
+Icon=pacpl
+Exec=/usr/share/pacpl/bin/PACPL-Konvert %F
@@ -1,9 +1,9 @@
-#!/usr/bin/bash
+#!/bin/sh
echo
echo "Installing Nautilus Action Script......"
echo
-cp -v PACPL-Convert $HOME/.local/share/nautilus/scripts
+ln -sv /usr/share/pacpl/bin/PACPL-Convert $HOME/.local/share/nautilus/scripts
echo
sleep 1
-echo "Done.."
\ No newline at end of file
+echo "Done.."
@@ -1,7 +1,7 @@
[Nemo Action]
Name=Perl Audio Converter
Comment=Perl Audio Converter
-Exec=/usr/share/nemo/actions/PACPL-Convert %F
+Exec=/usr/share/pacpl/bin/PACPL-Convert %F
Icon-Name=pacpl
Selection=Any
Extensions=dir;3G2;3GP;AAC;AC3;ADTS;AIF;AIFF;AMR;APE;AU;AVR;BONK;CAF;CDR;DTS;FAP;FLA;FLAC;IRCAM;LA;M4A;MAT;MAT4;MAT5;MMF;MP2;MP3;MP3HD;MP4;MPC;MPP;NIST;OFF;OFR;OFS;OGG;OPUS;PAF;PVF;RA;RAW;RM;SD2;SF;SHN;SMP;SND;SPX;TTA;VOC;W64;WAV;WMA;WV
@@ -4,16 +4,14 @@
CONFIG=${HOME}/.config/Thunar/uca.xml
-cp -v PACPL-Convert /usr/bin/
-
# Insert lines at end of Thunars $CONFIG
sed -i 's/<\/actions>//' $CONFIG
sed -i '/^$/d' $CONFIG
echo "
<action>
- <icon>/etc/pacpl/pacpl.png</icon>
+ <icon>/usr/share/icons/pacpl.png</icon>
<name>Perl Audio Converter</name>
- <command>/usr/bin/PACPL-Convert %F</command>
+ <command>/usr/share/pacpl/bin/PACPL-Convert %F</command>
<description>Linux Audio Converter / Tagger/ Ripper</description>
<patterns>*</patterns>
<directories/>
@@ -1,16 +1,16 @@
You will have to install the plugin manually using the following:
-1) sudo ./install-gnome.sh
+1) ./install-gnome.sh
This will modify ${HOME}/.config/Thunar/uca.xml
-and copy the supporting application/icon to their respective locations.
2) You will also need to edit /etc/pacpl/pacpl.conf and change ZEN_DIR & ZEN_OPTS to 1
and make sure KDE_DIR & KDE_OPTS = 0
Note: this version can be used with the kde plugin on any system that
supports multiple desktop choices (Slackware for example) if need be.
-You will just need to run the install-kde.sh script instead and do
-the exact opposite of the step 2) above.
+You will just need to replace PACPL-Converter by PACPL-Konverter in
+your ${HOME}/.config/Thunar/uca.xml
+and do the exact opposite of the step 2) above.
Restart Thunar (if already open) to see the changes take effect.
|