1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
|
Description: fix test failure with python3.11
Forwarding is not needed because upcoming versions will get away with atomic
commands.
Author: Étienne Mollier <emollier@debian.org>
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1028856
Forwarded: not-needed
Last-Update: 2023-01-14
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
@@ -370,7 +370,7 @@
def test_atomiccmd__paths__key(tmp_path):
cmd = AtomicCmd(("echo", "-n", "%(TEMP_DIR)s"), OUT_STDOUT=AtomicCmd.PIPE)
cmd.run(tmp_path)
- path = cmd._proc.stdout.read()
+ path = cmd._proc.stdout.read().decode()
assert tmp_path.samefile(path), (tmp_path, path)
assert cmd.join() == [0]
|