1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
|
%:
dh $@
FAILBOOTDIR = $(CURDIR)/debian/partclone/usr/share/partclone
MAN8DIR = $(CURDIR)/debian/partclone/usr/share/man/man8
override_dh_auto_configure:
sh ./autogen
dh_auto_configure -- --prefix=/usr --enable-ncursesw \
--enable-xfs \
--enable-extfs \
--disable-reiserfs \
--disable-reiser4 \
--enable-hfsp \
--enable-apfs \
--enable-fat \
--enable-exfat \
--enable-ntfs \
--disable-ufs \
--disable-vmfs \
--disable-jfs \
--enable-btrfs \
--enable-minix \
--enable-f2fs \
--disable-nilfs2
override_dh_clean: # keep the special file fail-mbr/fail-mbr.bin.orig
dh_clean
cp debian/fail-mbr.bin fail-mbr/fail-mbr.bin.orig
rm -f depcomp missing compile
rm -f Makefile.in
rm -f aclocal.m4
rm -f config.h.in
rm -f configure
rm -f config.log
rm -f docs/Makefile.in
rm -f fail-mbr/Makefile.in
rm -f ltmain.sh
rm -rf m4/
rm -f src/Makefile.in
rm -f tests/Makefile.in
rm -f docs/partclone.8 docs/partclone.info.8
override_dh_auto_test:
echo Skipping tests.
override_dh_auto_install:
dh_auto_install
install -d $(FAILBOOTDIR)
cp fail-mbr/fail-mbr.bin $(FAILBOOTDIR)
install -d $(MAN8DIR)
cd $(MAN8DIR); \
ln -s partclone.fat.8.gz partclone.vfat.8.gz; \
ln -s partclone.fat.8.gz partclone.fat12.8.gz; \
ln -s partclone.fat.8.gz partclone.fat16.8.gz; \
ln -s partclone.fat.8.gz partclone.fat32.8.gz; \
ln -s partclone.hfsp.8.gz partclone.hfs+.8.gz; \
ln -s partclone.hfsp.8.gz partclone.hfsplus.8.gz; \
ln -s partclone.extfs.8.gz partclone.ext2.8.gz; \
ln -s partclone.extfs.8.gz partclone.ext3.8.gz; \
ln -s partclone.extfs.8.gz partclone.ext4.8.gz; \
ln -s partclone.extfs.8.gz partclone.ext4dev.8.gz
rm -rf $(CURDIR)/debian/partclone/usr/share/man/dd
|