1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
Description: Newer versions of pygame.mixer having issues with .xm files.
The .xm files included seem to have varying sample rates so we convert
them to .ogg files at build time and patched the source to load them
instead of the .xm files.
The .xm files have been removed from the binary packages in favor of the
.ogg files.
Origin: vendor, http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=705415
Bug-Debian: http://bugs.debian.org/705415
Author: Barry deFreese <bdefreese@debian.org>
@@ -1614,7 +1614,7 @@
popup("Please wait...\n", (150, 50))
- start_music("background.xm", ingame_music_volume)
+ start_music("background.ogg", ingame_music_volume)
self.highscores.current_score = -1
@@ -1998,7 +1998,7 @@
self.draw()
- start_music("intro.xm", intro_music_volume)
+ start_music("intro.ogg", intro_music_volume)
while 1:
# Wait for the next frame
|