1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
|
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ifeq ($(DEB_HOST_ARCH_OS),hurd)
EXTRA_CONFIGURE_ARGS += --disable-usb
endif
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@ --with systemd,autoreconf --parallel
override_dh_auto_configure:
dh_auto_configure -- $(EXTRA_CONFIGURE_ARGS) --with-systemdsystemunitdir=/lib/systemd/system --enable-usbdropdir=/usr/lib/pcsc/drivers $(shell dpkg-buildflags --export=configure)
override_dh_strip:
dh_strip --dbg-package=libpcsclite1-dbg
|