1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=peewee
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
PYTHONPATH=. python3 -m sphinx -N -bhtml docs/ docs/build/html
PYTHONPATH=. python3 -m sphinx -N -bman docs/ docs/build/man
override_dh_install:
dh_install
mkdir -p debian/peewee/usr/bin/
mv debian/python3-peewee/usr/bin/pwiz.py \
debian/peewee/usr/bin/pwiz
override_dh_installman:
mkdir -p debian/peewee/usr/share/man/man1/
PYTHONPATH=. help2man --version-string $(DEB_VERSION_UPSTREAM) \
--no-info \
--name "peewee model generator" \
debian/peewee/usr/bin/pwiz > \
debian/peewee/usr/share/man/man1/pwiz.1
cp docs/build/man/peewee.1 debian/peewee/usr/share/man/man1/
|