File: README.OSF

package info (click to toggle)
perl-tk 1:804.033-2
  • links: PTS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 34,724 kB
  • ctags: 37,174
  • sloc: ansic: 349,541; perl: 52,192; sh: 17,904; makefile: 5,732; asm: 3,565; ada: 1,681; pascal: 1,089; cpp: 1,006; yacc: 883; cs: 879
file content (35 lines) | stat: -rw-r--r-- 590 bytes parent folder | download | duplicates (9)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35

OSF's 'make' has problems with the Makefiles constructed by MakeMaker
before MakeMaker-4.18

make
just says:
`Makefile' is up to date.

Using GNU make solves this.

Otherwise type:

make all

and do 'install' by hand:

make all

perl ./basic_demo

cp -r blib /usr/local/lib/perl5

Note that the cp -r does *not* do quite the same as a make install,
in particular the binaries are not separated from the scripts.

On Alpha if you get something like:

GC already registered in Tk_GetGC
Tcl_Panic at ...

Then it has been reported that reducing optimize from -O4 to -O3
fixes the problem.