1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
|
export PYBUILD_NAME = pexpect
export PYBUILD_TEST_ARGS = -k 'not (pxssh or replwrap or test_before_across_chunks or test_spawn_uses_env)'
export TRAVIS = 1
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_clean:
dh_auto_clean
rm -rf .coverage
override_dh_auto_build:
dh_auto_build
PYTHONPATH=. http_proxy='127.0.0.1:9' python3 -m sphinx -N -bhtml doc/ build/html
override_dh_installdocs:
dh_installdocs -ppython-pexpect-doc build/html
dh_installdocs -A
|