File: changelog

package info (click to toggle)
php-codecoverage 6.1.4+dfsg-1
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 2,324 kB
  • sloc: php: 5,958; xml: 924; makefile: 28; sh: 5
file content (508 lines) | stat: -rw-r--r-- 13,743 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
php-codecoverage (6.1.4+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

 -- David Prévot <taffit@debian.org>  Fri, 02 Nov 2018 07:17:29 +1300

php-codecoverage (6.1.3+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

 -- David Prévot <taffit@debian.org>  Tue, 23 Oct 2018 18:10:11 -1000

php-codecoverage (6.1.1+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Delete old ChangeLog files
  * Allow sebastian/environment ^4.0
  * Prepare release

  [ Remon van de Kamp ]
  * Update bootstrap for HTML coverage to version 4

  [ David Prévot ]
  * Drop old changelog entries removed upstream
  * Update copyright (years)
  * Adapt package to removed files (Closes: #908428)
  * Add popper.js sources

 -- David Prévot <taffit@debian.org>  Fri, 19 Oct 2018 11:40:31 -1000

php-codecoverage (6.0.8+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Remove superfluous realpath() call
  * Prepare release

  [ Netmosfera ]
  * Cache the result of `is_file()` calls.

  [ David Prévot ]
  * Use debhelper-compat 11
  * Drop get-orig-source target
  * Use https in Format
  * Update Standards-Version to 4.2.1

 -- David Prévot <taffit@debian.org>  Sat, 06 Oct 2018 09:42:13 -1000

php-codecoverage (6.0.7+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Use phpunit/php-file-iterator ^2.0
  * Prepare release

  [ David Prévot ]
  * Adapt homemade autoload to php-file-iterator 2
  * Use recent PHPUnit for the tests

 -- David Prévot <taffit@debian.org>  Wed, 20 Jun 2018 10:31:08 -1000

php-codecoverage (6.0.4+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

 -- David Prévot <taffit@debian.org>  Wed, 16 May 2018 19:03:04 -1000

php-codecoverage (6.0.3+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

  [ David Prévot ]
  * Update Standards-Version to 4.1.4

 -- David Prévot <taffit@debian.org>  Fri, 20 Apr 2018 09:35:46 -1000

php-codecoverage (6.0.1+dfsg-2) unstable; urgency=medium

  * Team upload, to unstable, with the rest of the latest PHPUnit stack
  * Drop Luis Uribe from Uploaders (Closes: #894004)

 -- David Prévot <taffit@debian.org>  Thu, 29 Mar 2018 10:08:15 -1000

php-codecoverage (6.0.1+dfsg-1) experimental; urgency=medium

  * Team upload to experimental since phpunit/sid currently depends on
    php-codecoverage (<< 6~~)

  [ Sebastian Bergmann ]
  * Start development of php-code-coverage 6.0
  * Update ChangeLog
  * Prepare release

  [ David Prévot ]
  * Move project repository to salsa.d.o
  * Update Standards-Version to 4.1.3

 -- David Prévot <taffit@debian.org>  Sun, 04 Mar 2018 18:44:18 -1000

php-codecoverage (5.3.0+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Bump copyright year
  * Add option to ignore forceCoversAnnotation=true for a single test
  * Prepare release

  [ David Prévot ]
  * Update copyright (years)
  * Update Standards-Version to 4.1.2

 -- David Prévot <taffit@debian.org>  Fri, 08 Dec 2017 17:38:18 -1000

php-codecoverage (5.2.4+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Update fixture for php-token-stream ^2.0 (anonymous function -> anonymousFunction#%d#%d)
  * Prepare release

 -- David Prévot <taffit@debian.org>  Fri, 01 Dec 2017 16:16:16 -1000

php-codecoverage (5.2.2+dfsg-2) unstable; urgency=medium

  * Team upload
  * Upload to unstable, with the rest of the latest PHPUnit stack
  * Build-depend on recent phpunit (Closes: #877245)
  * Update Standards-Version to 4.1.1

 -- David Prévot <taffit@debian.org>  Sat, 25 Nov 2017 16:57:58 -1000

php-codecoverage (5.2.2+dfsg-1) experimental; urgency=medium

  * Team upload
  * Upload version only compatible with latest PHPUnit to experimental

  [ Sebastian Bergmann ]
  * Allow phpunit/php-token-stream ^2.0
  * Allow sebastian/environment ^3.0
  * Prepare release

  [ David Prévot ]
  * Drop Thomas Goirand from uploaders as he requested
  * Adapt package to new php-tokenizer dependency
  * Update Standards-Version to 4.1.0
  * Adapt test calls to now common build.xml path
  * Adapt d/rules to removed build directory upstream
  * Ensure the local class takes precedence during tests

 -- David Prévot <taffit@debian.org>  Wed, 23 Aug 2017 15:44:52 -1000

php-codecoverage (4.0.0+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Initial work on moving to namespaces
  * Update HTML assets
  * Prepare release

  [ David Prévot ]
  * Update files path for version 4
  * Update copyright and missing sources

 -- David Prévot <taffit@debian.org>  Sat, 04 Jun 2016 14:06:24 -0400

php-codecoverage (3.3.3+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

 -- David Prévot <taffit@debian.org>  Sat, 28 May 2016 18:49:14 -0400

php-codecoverage (3.3.1+dfsg-2) unstable; urgency=medium

  * Team upload

  [ Remi Collet ]
  * Fix for phpunit-environment 1.3.6 (Closes: #824047)

 -- David Prévot <taffit@debian.org>  Wed, 11 May 2016 13:57:19 -0400

php-codecoverage (3.3.1+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Handle lines with declare statements correctly

  [ David Prévot ]
  * Update Standards-Version to 3.9.8

 -- David Prévot <taffit@debian.org>  Sun, 10 Apr 2016 20:33:53 -0400

php-codecoverage (3.3.0+dfsg-1) unstable; urgency=medium

  * Team upload
  * Revert "Workaround #814858", and build with recent pkg-php-tools for the
    PHP 7.0 transition.

 -- David Prévot <taffit@debian.org>  Sat, 05 Mar 2016 19:43:22 -0400

php-codecoverage (3.2.1+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Marco Pivetta ]
  * In order to support PHP 7.0, token stream PHP7 tokens are required

  [ David Prévot ]
  * Convert build-dependencies to be PHP 7.0 ready (Closes: #814816)
  * Workaround #814858.
    Workaround the ongoing yet not ready PHP 7.0 transition:
    - build-depend on php-cli to use php7.0 at build time;
    - pkgtools called with -v triggers a segfault;

 -- David Prévot <taffit@debian.org>  Mon, 22 Feb 2016 23:03:05 -0400

php-codecoverage (3.2.0+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

  [ David Prévot ]
  * New phpunit-code-unit-reverse-lookup dependency

 -- David Prévot <taffit@debian.org>  Sat, 13 Feb 2016 14:33:53 -0400

php-codecoverage (3.1.1+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

  [ David Prévot ]
  * Update Standards-Version to 3.9.7
  * Simplify lack of PSR-4 support workaround

 -- David Prévot <taffit@debian.org>  Fri, 05 Feb 2016 15:27:01 -0400

php-codecoverage (3.1.0+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Maks3w ]
  * Remove old feature mapTestClassNameToCoveredClassName
  * Add method visibility to Clover report
  * Add cyclomatic complexity to Clover report

  [ Sebastian Bergmann ]
  * Prepare release

  [ Christian Rishøj ]
  * PHP 7 compatibility

 -- David Prévot <taffit@debian.org>  Sat, 16 Jan 2016 20:30:44 -0400

php-codecoverage (3.0.2+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

  [ David Prévot ]
  * Revert "Force loading of xdebug"

 -- David Prévot <taffit@debian.org>  Sat, 21 Nov 2015 12:07:24 -0400

php-codecoverage (3.0.1+dfsg-3) unstable; urgency=medium

  * Binary upload, since phpunit can’t be installed currently.

 -- David Prévot <taffit@debian.org>  Mon, 02 Nov 2015 14:53:13 -0400

php-codecoverage (3.0.1+dfsg-2) unstable; urgency=medium

  * Team upload, to unstable since everything is in place
  * Revert "Temporarily drop patch"
  * Bump build-dependencies

 -- David Prévot <taffit@debian.org>  Fri, 30 Oct 2015 15:51:10 -0400

php-codecoverage (3.0.1+dfsg-1) experimental; urgency=medium

  * Team upload, to experimental since current phpunit depends on
    php-codecoverage (<< 3~~)

  [ Sebastian Bergmann ]
  * Drop support for PHP < 5.6
  * Add ChangeLog for PHP_CodeCoverage 3.0

  [ David Prévot ]
  * Revert "Track version 2 as currently needed by phpunit"
  * Temporarily drop patch and use the installed package for tests

 -- David Prévot <taffit@debian.org>  Mon, 26 Oct 2015 15:36:57 -0400

php-codecoverage (2.2.4+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Fix CS/WS issues
  * Update nv.d3.js
  * Initial work on ChangeLog

  [ David Prévot ]
  * Track version 2 as currently needed by phpunit
  * Use now available upstream changelog
  * Update copyright and missing sources for nvd3
  * Force loading of xdebug (Closes: #796408)

 -- David Prévot <taffit@debian.org>  Sun, 25 Oct 2015 23:00:24 -0400

php-codecoverage (2.1.7+dfsg-1) unstable; urgency=medium

  * Team upload

 -- David Prévot <taffit@debian.org>  Sat, 11 Jul 2015 17:04:24 -0400

php-codecoverage (2.1.6+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Make threshold configurable

 -- David Prévot <taffit@debian.org>  Mon, 29 Jun 2015 17:45:35 -0400

php-codecoverage (2.1.5+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Jeremy Benoist ]
  * Restore compatibility with PHP 5.3

 -- David Prévot <taffit@debian.org>  Sun, 14 Jun 2015 18:05:19 -0400

php-codecoverage (2.1.4+dfsg-1) unstable; urgency=medium

  * Team upload

  [ Sebastian Bergmann ]
  * Prepare release

  [ Graham Campbell ]
  * Updated holder.js to 2.7.1
  * Updated d3 libs

  [ David Prévot ]
  * Update copyright and missing sources
  * Minify JavaScript files at build time
  * Minify CSS file from source
  * Simplify phpunit call

 -- David Prévot <taffit@debian.org>  Mon, 08 Jun 2015 17:58:55 -0400

php-codecoverage (2.0.16+dfsg-1) unstable; urgency=medium

  * Team upload, to unstable since Jessie is released

  [ Sebastian Bergmann ]
  * Prepare release

 -- David Prévot <taffit@debian.org>  Wed, 15 Apr 2015 23:31:14 -0400

php-codecoverage (2.0.15+dfsg-1) experimental; urgency=medium

  * Team upload, to experimental to respect the freeze

  [ Graham Campbell ]
  * Updated to bootstrap 3.3.2
  * Updated d3 from 3.4.11 to 3.4.13
  * Updated holder from 2.3.2 to 2.4.1

  [ Sebastian Bergmann ]
  * Prepare release

  [ Henrique Moody ]
  * Update license and copyright in all files

  [ David Prévot ]
  * Load dependencies (Closes: #777380)
  * Use recent phpunit-environment
  * Update missing sources
  * Update copyright

 -- David Prévot <taffit@debian.org>  Tue, 10 Feb 2015 21:19:29 -0400

php-codecoverage (2.0.11+dfsg-3) unstable; urgency=medium

  * Team upload
  * Use libjs-bootstrap
  * Use repacksuffix feature of uscan

 -- David Prévot <taffit@debian.org>  Sun, 26 Oct 2014 04:54:12 -0400

php-codecoverage (2.0.11+dfsg-2) unstable; urgency=medium

  * Team upload
  * Upload to unstable, as needed by phpunit 4
  * Bump standards version to 3.9.6

 -- David Prévot <taffit@debian.org>  Sat, 04 Oct 2014 21:01:14 -0400

php-codecoverage (2.0.11+dfsg-1) experimental; urgency=medium

  * Team upload

  [ Mathieu Parent ]
  * Remove me from uploaders

  [ David Prévot ]
  * Add missing sources
  * Update copyright
  * Restart packaging for Composer source
  * Minify JavaScript files from source
  * Update links to external files
  * Ship README
  * Add upstream changelog
  * Enable test during package build
  * Add DEP-8 compliant tests
  * Upload to experimental because phpunit 3.7.28-1 depends on
    php-codecoverage (<= 1.2.99)

 -- David Prévot <taffit@debian.org>  Sat, 13 Sep 2014 14:32:54 -0400

php-codecoverage (1.2.13+dfsg2-1) unstable; urgency=medium

  * Remove sourceless minified Javascript and CSS files
    - Update debian/gbp.conf
    - Create new +dfsg2 without those files (Closes: #737453)
    - Depend on libjs-twitter-bootstrap
    - Remove references to embedded libjs-twitter-bootstrap in package.xml
  * Change maintainer name to "Debian PHP PEAR Maintainers"
  * Update copyright for new upstream version
  * Add myself as uploader

 -- Prach Pongpanich <prachpub@gmail.com>  Sun, 09 Feb 2014 14:55:32 +0700

php-codecoverage (1.2.13+dfsg1-1) unstable; urgency=medium

  * New version
    - YUI2 is not used anymore (Closes: #733962)
  * gbp.conf: Use pristine-tar and remove non-free highcharts.js
  * Updated VCS-* fields to canonical
  * Add myself to uploaders
  * Use ${phppear:Debian-Depends/Recommends/Breaks}
  * Remove all patches
  * Remove references of Highcharts
  * Use ${phppear:summary} and ${phppear:description}
  * Update to Standards-Version: 3.9.5 (no change)
  * Override PEAR package names
  * Move to debhelper 9
  * Remove unneeded target delete_nonfree_from_upstream
  * Check for non-free files
  * Replace jquery.min.js by a symlink
  * Depends on php5-cli (>= 5.3.7-1~) which provides PEAR 1.9.4
    (Closes: #693679)
  * Comment out references to highcharts.js

 -- Mathieu Parent <sathieu@debian.org>  Wed, 08 Jan 2014 19:45:02 +0100

php-codecoverage (1.1.2+dfsg1-3) unstable; urgency=low

  * debian/patches
    - Adding remove_highcharts.diff to remove highcharts.js from html
    generated report (Closes: #684280).
  * README.Debian
    - Adding file

 -- Luis Uribe <acme@eviled.org>  Wed, 05 Sep 2012 13:37:45 -0500

php-codecoverage (1.1.2+dfsg1-2) unstable; urgency=low

  * Correctly sets the copyright for YUI files.

 -- Thomas Goirand <zigo@debian.org>  Fri, 11 May 2012 06:52:21 +0000

php-codecoverage (1.1.2+dfsg1-1) unstable; urgency=low

  * Initial release (Closes: #610676).

 -- Thomas Goirand <zigo@debian.org>  Fri, 09 Mar 2012 10:01:47 +0000