1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
|
%:
dh $@
override_dh_auto_build:
phpabtpl --basedir src composer.json > debian/autoload.php.tpl
phpab \
--output src/autoload.php \
--template debian/autoload.php.tpl \
src
mkdir --parents vendor GuzzleHttp
phpabtpl \
--require guzzlehttp/psr7 \
--require http-interop/http-factory-tests \
> debian/autoload.tests.php.tpl
phpab \
--output vendor/autoload.php \
--template debian/autoload.tests.php.tpl \
tests
ln -s ../src GuzzleHttp/Psr7
override_dh_auto_test:
php -S 127.0.0.1:10002 tests/Integration/server.php &
TEST_SERVER=127.0.0.1:10002 phpunit -v
|