1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
|
%:
dh $@ --with phpcomposer
include /usr/share/dpkg/default.mk
override_dh_auto_build:
phpab --output src/autoload.php src
mkdir --parents League share vendor
ln -s ../src League/CommonMark
ln -s .. share/php
phpab \
--output vendor/autoload.php \
--template debian/autoload.tests.php.tpl \
tests
override_dh_auto_test:
phpunit
execute_before_dh_installman:
mkdir --parents $(CURDIR)/debian/tmp
help2man \
--help-option=\ \
--version-string=$(DEB_VERSION_UPSTREAM) \
--no-info \
--source="commonmark $(DEB_VERSION_UPSTREAM)" \
--include=$(CURDIR)/debian/commonmark.1.in \
"$(CURDIR)/bin/commonmark -h | tail -n+3" \
> $(CURDIR)/debian/tmp/commonmark.1
|