1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
|
From: =?utf-8?q?David_Pr=C3=A9vot?= <taffit@debian.org>
Date: Wed, 12 Mar 2025 07:23:37 +0100
Subject: Modernize PHPUnit syntax
tests/PhpOption/Tests/LazyOptionTest.php | 2 ++
1 file changed, 2 insertions(+)
diff --git a/tests/PhpOption/Tests/LazyOptionTest.php b/tests/PhpOption/Tests/LazyOptionTest.php
index e1b5128..32485d4 100644
@@ -6,6 +6,7 @@ use PhpOption\LazyOption;
use PhpOption\None;
use PhpOption\Option;
use PhpOption\Some;
+use PHPUnit\Framework\Attributes\RequiresPhpunit;
use PHPUnit\Framework\TestCase;
class LazyOptionTest extends TestCase
@@ -173,6 +174,7 @@ class LazyOptionTest extends TestCase
self::assertSame($some, $lazy->orElse(Some::create('bar')));
}
+ #[RequiresPhpunit('< 12')]
public function testFoldLeftRight(): void
{
$callback = function () {
|