File: changelog

package info (click to toggle)
php-pimple 3.3.1-1
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 232 kB
  • sloc: php: 886; makefile: 16
file content (156 lines) | stat: -rw-r--r-- 4,479 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
php-pimple (3.3.1-1) unstable; urgency=medium

  * d/pimple.ini: Remove useless file
  * d/control: Remove unneeded dh-php build dep
  * d/control: Remove unneeded version restriction on phpunit
  * New upstream version 3.3.1
  * Update watch file format version to 4.

 -- James Valleroy <jvalleroy@mailbox.org>  Thu, 26 Nov 2020 12:31:17 -0500

php-pimple (3.3.0-1) unstable; urgency=medium

  [ David Prévot ]
  * Drop myself from uploaders
  * Rename autoload template for ci
  * Adapt homemade autoload to new dependency

  [ Dmitry Smirnov ]
  * New upstream release (Closes: #915863)
  * New patch to fix "php-pimple FTBFS with phpunit 6.4.4-2"
    (Closes: #882902).
  * Build-Depends:
    = phpunit (>= 7.2.7~)
    + php-symfony-phpunit-bridge
  * Removed php5 leftovers.
  * Vcs URLs to Salsa.
  * Standards-Version: 4.1.5.
  * debhelper & compat to version 11.

  [ James Valleroy ]
  * d/salsa-ci.yml: Add CI pipeline
  * d/tests/control: Add @ to Depends for as-installed test
  * d/tests/control: Remove redundant test command (Closes: #827390).
  * d/control: Add myself as another uploader
  * d/control: Bump standards version to 4.5.0
  * d/source: Remove unused override
  * Use secure URI in Homepage field.
  * d/upstream: Add metadata
  * d/control: Use debhelper-compat=13
  * d/control: Add Rules-Requires-Root: no
  * d/control: Remove very old version restrictions
  * New upstream version 3.3.0
  * d/clean: Remove obsolete entries
  * d/rules: Remove override_dh_auto_clean and cleanup file
  * d/patches: Drop obsolete patch
  * Include Symfony/Bridge/PhpUnit in autoloader for tests
  * d/tests/control: Add php-symfony-phpunit-bridge dependency
  * d/copyright: Update upstream copyright years
  * d/clean: Add .phpunit.result.cache

 -- James Valleroy <jvalleroy@mailbox.org>  Sat, 06 Jun 2020 12:57:39 -0400

php-pimple (3.0.2-2) unstable; urgency=medium

  * Upload to unstable.
  * No longer build PHP-7 incompatible C extension.
  * Standards-Version: 3.9.8.
  * Upgraded Vcs-Browser URL.
  * Removed rules/get-orig-source.
  * Added myself to Uploaders.

 -- Dmitry Smirnov <onlyjob@debian.org>  Sun, 10 Apr 2016 11:42:09 +1000

php-pimple (3.0.2-1) experimental; urgency=medium

  [ Fabien Potencier ]
  * moved to silexphp organization
  * updated CHANGELOG
  * prepared the 3.0.2 release

  [ Marcus Sa ]
  * Update license year.

  [ David Prévot ]
  * Update upstream VCS
  * Update copyright (years)
  * Drop description from composer.json

 -- David Prévot <taffit@debian.org>  Thu, 29 Oct 2015 21:11:26 -0400

php-pimple (3.0.0-2) experimental; urgency=medium

  * Bump standards version to 3.9.6
  * Provide homemade autoload.php
  * Run all tests

 -- David Prévot <taffit@debian.org>  Wed, 13 May 2015 18:26:43 -0400

php-pimple (3.0.0-1) experimental; urgency=medium

  [ Fabien Potencier ]
  * updated CHANGELOG
  * moved tests under src/
  * prepare 3.0.0 release

  [ David Prévot ]
  * Do not install extension instead of skipping a class test
  * Do not care about the class for the extension test
  * Do not install tests
  * Adapt patches to moved tests

 -- David Prévot <taffit@debian.org>  Sat, 26 Jul 2014 23:39:17 -0400

php-pimple (2.1.0-2) experimental; urgency=medium

  * Build C extension

 -- David Prévot <taffit@debian.org>  Thu, 03 Jul 2014 12:00:58 -0400

php-pimple (2.1.0-1) experimental; urgency=medium

  [ Fabien Potencier ]
  * bumped version to 2.1
  * moved lib/ to src/
  * migrated everything to Pimple\Container

  [ Julien Pauli ]
  * Pimple C extension

  [ Adrian Cendrowski ]
  * Updated license year

  [ David Prévot ]
  * No tests if DEB_BUILD_OPTIONS contains nocheck
  * Update copyright
  * Update packaging
  * Update patches
  * Update dependencies

 -- David Prévot <taffit@debian.org>  Thu, 03 Jul 2014 10:08:21 -0400

php-pimple (2.0.0-1) experimental; urgency=medium

  [ Fabien Potencier ]
  * added a CHANGELOG

  [ David Prévot ]
  * Revert "Stick to version 1 as needed by Silex", and upload to experimental

 -- David Prévot <taffit@debian.org>  Wed, 28 May 2014 10:00:41 -0400

php-pimple (1.1.1-1) unstable; urgency=medium

  [ Fabien Potencier ]
  * bumped Pimple version

  [ David Prévot ]
  * Stick to version 1 as needed by Silex

 -- David Prévot <taffit@debian.org>  Wed, 28 May 2014 08:52:18 -0400

php-pimple (1.0.2-1) unstable; urgency=low

  * Initial release (closes: #748869)

 -- David Prévot <taffit@debian.org>  Wed, 21 May 2014 12:41:53 -0400