File: control

package info (click to toggle)
php-validate 0.8.5-4.1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 244 kB
  • ctags: 352
  • sloc: php: 758; xml: 492; makefile: 2
file content (23 lines) | stat: -rw-r--r-- 942 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
Source: php-validate
Section: php
Priority: optional
Maintainer: Dario Minnucci <midget@debian.org>
Build-Depends: debhelper (>= 9), pkg-php-tools
Standards-Version: 3.9.5
Homepage: http://pear.php.net/package/Validate
Vcs-Git: git://anonscm.debian.org/collab-maint/php-validate.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=collab-maint/php-validate.git

Package: php-validate
Architecture: all
Depends: ${misc:Depends}, ${phppear:Debian-Depends}
Recommends: ${phppear:Debian-Recommends}
Breaks: ${phppear:Debian-Breaks}
Description: validation class
 This package provides a PEAR package for validating data, including:
  * numbers (min/max, decimal or not);
  * email (syntax, domain check, RFC 822 compliance);
  * strings (predefined type alpha upper and/or lowercase, numeric, etc.);
  * dates (min/max, RFC 822 compliance);
  * URIs (RFC 2396 compliance).
 Multiple checks can be performed by a single method call (::multiple).