File: 0001-Use-homemade-autoload.patch

package info (click to toggle)
phpmd 2.6.0-1
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 680 kB
  • ctags: 774
  • sloc: php: 3,320; xml: 1,022; makefile: 21
file content (30 lines) | stat: -rw-r--r-- 870 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
From: =?utf-8?q?David_Pr=C3=A9vot?= <david@tilapin.org>
Date: Sat, 24 Jan 2015 21:53:10 -0400
Subject: Use homemade autoload

Work around the lack of proper Composer support.

Forwarded: not-needed
---
 src/bin/phpmd | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/bin/phpmd b/src/bin/phpmd
index f64b0f1..ddf994a 100755
--- a/src/bin/phpmd
+++ b/src/bin/phpmd
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
 <?php
 
 use PHPMD\TextUI\Command;
@@ -7,7 +7,7 @@ if (file_exists(__DIR__ . '/../../../../autoload.php')) {
     // phpmd is part of a composer installation
     require_once __DIR__ . '/../../../../autoload.php';
 } else {
-    require_once __DIR__ . '/../../vendor/autoload.php';
+    require_once 'PHPMD/autoload.php';
 
     // PEAR installation workaround
     if (strpos('@package_version@', '@package_version') === 0) {