1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
|
From: Michael R. Crusoe <crusoe@debian.org>
Subject: Skip Intel tests on non-Intel
--- a/src/test/java/picard/IntelInflaterDeflaterLoadTest.java
+++ b/src/test/java/picard/IntelInflaterDeflaterLoadTest.java
@@ -56,6 +56,10 @@
throw new SkipException(componentName + " is not available on this platform");
}
+ if (SystemUtils.OS_ARCH != null && !SystemUtils.OS_ARCH.equals("amd64")) {
+ throw new SkipException(componentName + " is not available for this architecture");
+ }
+
if (SystemUtils.OS_ARCH != null && SystemUtils.OS_ARCH.equals("ppc64le")) {
throw new SkipException(componentName + " is not available for this architecture");
}
|