File: control

package info (click to toggle)
pike7.8 7.8.866-7
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 69,304 kB
  • ctags: 28,082
  • sloc: ansic: 252,877; xml: 36,537; makefile: 4,214; sh: 2,879; lisp: 655; asm: 591; objc: 212; pascal: 157; sed: 34
file content (285 lines) | stat: -rw-r--r-- 12,192 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
Source: pike7.8
Section: interpreters
Priority: optional
Maintainer: Magnus Holmgren <holmgren@debian.org>
Uploaders: Henrik Andreasson <debian@han.pp.se>
Standards-Version: 3.9.8
Build-Depends: dpkg-dev (>= 1.15.7), debhelper (>= 5), bison, sharutils, bc, pkg-config,
 libgmp10-dev, nettle-dev (>= 2.1~), zlib1g-dev | libz-dev,
 libbz2-dev, libgdbm-dev, unixodbc-dev, default-libmysqlclient-dev, libpq-dev,
 libsqlite3-dev, libpcre3-dev, libsdl-mixer1.2-dev, libsdl1.2-dev,
 libsane-dev, x11proto-gl-dev, libxpm-dev, libglade2-dev,
 libgtksourceview2.0-dev, libfreetype6-dev, freeglut3-dev,
 libjpeg-dev, libtiff-dev, librsvg2-dev (>= 2.7), libgnomeui-dev,
 libfuse-dev, libfftw3-dev, libavahi-compat-libdnssd-dev,
 libkrb5-dev
Build-Conflicts: libutahglx-dev
Homepage: http://pike.lysator.liu.se/
Vcs-Svn: svn://anonscm.debian.org/pkg-pike/branches/7.8-stable
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-pike/

Package: pike7.8-core
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Suggests: pike7.8-doc
Description: Powerful interpreted programming language
 Pike is an interpreted, object-oriented, dynamic programming language
 with a syntax similar to C. It includes many powerful data types and
 a module system that, for instance, provides image manipulation
 together, with support for graphics formats like SVG, JPG, PNG, GIF,
 XCF and many others, database connectivity, advanced cryptography,
 XML/HTML parsers and others. To learn more about pike, please visit
 http://pike.lysator.liu.se/ Note that some of the Pike features are
 found in other pike7.8-* packages (image processing, MySQL,
 PostgreSQL, SANE and more).

Package: pike7.8
Architecture: all
Depends: pike7.8-core (>= ${source:Version}), pike7.8-image (>= ${source:Version}), 
 pike7.8-gdbm (>= ${source:Version}), pike7.8-pcre (>= ${source:Version}), ${misc:Depends}
Recommends: pike7.8-mysql (>= ${source:Version}), pike7.8-pg (>= ${source:Version}), pike7.8-dev (>= ${source:Version})
Suggests: pike7.8-doc (= ${source:Version})
Description: Recommended metapackage for Pike 7.8
 This is a metapackage which depends upon several other Pike
 packages that together make up the recommended Pike installation.
 If you want to install every packaged component of the Pike 
 distribution, please install the pike7.8-full package.
 .
 If you want to remove several components this package depends
 upon, you can purge this package without worrying about the
 functionality loss in Pike and then remove the packages you
 don't need on your system.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-dev
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends},
 pike7.8-core (= ${binary:Version}), pike7.8-image (= ${binary:Version})
Replaces: pike7.8-core (<< 7.8.352-dfsg-6)
Breaks: pike7.8-core (<< 7.8.352-dfsg-6)
Description: Development files for Pike 7.8
 This package contains files you will need to develop C extension modules 
 for Pike. The package depends on the recommended set of packages for the 
 Pike environment.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-manual
Architecture: all
Section: doc
Depends: ${misc:Depends}
Description: Pike 7.8 manual
 The Pike manual auto-generated from the sources.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-reference
Architecture: all
Section: doc
Depends: ${misc:Depends}
Description: Pike 7.8 reference
 The Pike reference auto-generated from the sources.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-doc
Architecture: all
Section: doc
Depends: ${misc:Depends}, pike7.8-manual (= ${source:Version}), pike7.8-reference (= ${source:Version})
Description: Pike 7.8 documentation metapackage
 This package depends upon all the Pike 7.8 documentation  packages. Note 
 that the download and installation sizes might be very large.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-full
Architecture: all
Depends: ${misc:Depends}, pike7.8 (= ${source:Version}), pike7.8-mysql (>= ${source:Version}), pike7.8-pg (>= ${source:Version}), pike7.8-odbc (>= ${source:Version}), pike7.8-sdl (>= ${source:Version}), pike7.8-gdbm (>= ${source:Version}), pike7.8-gtk (>= ${source:Version}), pike7.8-gl (>= ${source:Version}), pike7.8-sane (>= ${source:Version}), pike7.8-doc (= ${source:Version}), pike7.8-dev (>= ${source:Version}), pike7.8-svg (>= ${source:Version}), pike7.8-pcre (>= ${source:Version}), pike7.8-bzip2 (>= ${source:Version}), pike7.8-fuse (>= ${source:Version}), pike7.8-sqlite (>= ${source:Version}), pike7.8-dnssd (>= ${source:Version}), pike7.8-kerberos (>= ${source:Version})
Description: Metapackage for Pike 7.8
 This package depends on all the components that make up the Pike
 language distribution. It will pull in a LOT of packages the
 Pike components depend upon (including XFree libraries, GTK+, GNOME)!
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-mysql
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: MySQL modules for Pike
 This package contains Pike modules providing access to MySQL
 databases: Mysql and Sql.mysql(s).
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-pg
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: PostgreSQL modules for Pike
 This package contains Pike module providing access to PostgreSQL
 databases: Postgres, Sql.postgres, and Sql.postgres_result.
 .
 Note: These modules are deprecated in favour of the pure Pike
 Sql.pgsql module, which is included in the core package.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-odbc
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: ODBC modules for Pike
 This package contains Pike modules providing glue to the ODBC
 interface: Odbc, Sql.odbc, and Sql.odbc_result.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-svg
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Suggests: pike7.8-image (= ${source:Version})
Description: SVG format support for Pike
 This package provides an SVG graphics format module, Image.SVG. It
 has been separated from the pike7.8-image module because of its quite
 extensive dependencies.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-image
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Replaces: pike7.8-core (<< 7.8.700-6)
Breaks: pike7.8-core (<< 7.8.700-6)
Suggests: pike7.8-svg (= ${source:Version})
Description: Image modules for Pike
 This package provides many powerful image processing functions to
 Pike programs. It contains the modules Image (except Image.SVG),
 Graphics, Colors, and Protocols.X.XImage.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-sdl
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: SDL module for Pike
 This module provides the Pike interface to the SDL library.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-gdbm
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: Gdbm module for Pike
 This Pike module provides access to gdbm databases.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-gtk
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version}),
 pike7.8-image (= ${binary:Version})
Replaces: pike7.8-core (<< 7.8.700-5)
Breaks: pike7.8-core (<< 7.8.700-5)
Description: GTK+ 2.0 module for Pike
 This Pike module provides access to the GTK+ 2.0 library.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-gl
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: Mesa modules for Pike
 This package contains the Pike modules providing access to the Mesa
 3D graphics library: GL, GLU (GL Utilities), and GLUE (GL Universal
 Environment).
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-sane
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: SANE module for Pike
 This Pike module provides access to SANE.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-pcre
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: PCRE module for Pike
 This Pike module (Regexp.PCRE) enables one to use the PCRE (Perl
 compatible regular expressions) library from within the Pike
 programs.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-bzip2
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: Bzip2 module for Pike
 This Pike module enables one to use the Bzip2 compression
 algorithm from within the Pike programs.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-fuse
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: Filesystem in USErspace support for Pike
 This Pike module enables one to export filesystems to the Linux
 kernel using the FUSE library.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-sqlite
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: SQLite module for Pike
 This Pike module enables one to use the SQLite embedded database
 library.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-dnssd
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Description: DNS Service Discovery (DNS-SD) for Pike
 This Pike module enables one to take advantage of DNS service discovery.
 .
 DNS Service Discovery is a way of using standard DNS programming interfaces,
 servers, and packet formats to browse the network for services.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.

Package: pike7.8-kerberos
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, pike7.8-core (= ${binary:Version})
Replaces: pike7.8-core (<< 7.8.866-2~)
Breaks: pike7.8-core (<< 7.8.866-2~)
Description: Kerberos and GSSAPI modules for Pike
 This package contains the Kerberos and GSSAPI Pike modules (although
 GSSAPI is a generic API; Kerberos is the most common mechanism),
 providing bindings to the Heimdal libraries.
 .
 Pike is an interpreted programming language, for more information 
 see the description of the pike7.8-core package.