1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
PACKAGE = libpixman-1-0
SHLIBS = 0.25.2
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
override_dh_auto_configure:
LS_CFLAGS=" " dh_auto_configure -- --disable-gtk \
--disable-arm-iwmmxt
override_dh_auto_install:
dh_auto_install --destdir=debian/tmp
override_dh_install:
find debian/tmp -name '*.la' -delete
dh_install --fail-missing
override_dh_strip:
dh_strip -p$(PACKAGE) --dbgsym-migration="$(PACKAGE)-dbg (<< 0.34.0-2~)"
dh_strip -N$(PACKAGE)
override_dh_makeshlibs:
dh_makeshlibs -p$(PACKAGE) --add-udeb $(PACKAGE)-udeb -V"$(PACKAGE) (>= $(SHLIBS))" -- -c4
override_dh_auto_test:
dh_auto_test -- VERBOSE=1
%:
dh $@ --with quilt --builddirectory=build/
|