1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223
|
Description: internal function declarations
Declare all internal functions used in other source files.
A lot of functions were not declared explicitly to be int or void.
.
pixmap (2.6.6-1) UNRELEASED; urgency=medium
.
* New upstream version.
Author: Paul Slootman <paul@debian.org>
---
Last-Update: 2021-11-23
Index: pixmap-2.6.6/SelFile/Draw.c
===================================================================
--- pixmap-2.6.6.orig/SelFile/Draw.c
+++ pixmap-2.6.6/SelFile/Draw.c
@@ -59,6 +59,7 @@ static int SFcurrentListY;
static XtIntervalId SFscrollTimerId;
+void
SFinitFont()
{
TextData *data;
@@ -86,6 +87,7 @@ SFinitFont()
SFcharHeight = SFcharAscent + SFfont->max_bounds.descent;
}
+void
SFcreateGC()
{
XGCValues gcValues;
@@ -151,6 +153,7 @@ SFcreateGC()
);
}
+void
SFclearList(n, doScroll)
int n;
int doScroll;
@@ -193,7 +196,7 @@ SFclearList(n, doScroll)
}
}
-static
+static void
SFdeleteEntry(dir, entry)
SFDir *dir;
SFEntry *entry;
@@ -244,7 +247,7 @@ SFdeleteEntry(dir, entry)
);
}
-static
+static void
SFwriteStatChar(name, last, statBuf)
char *name;
int last;
@@ -320,7 +323,7 @@ SFstatAndCheck(dir, entry)
return 0;
}
-static
+static void
SFdrawStrings(w, dir, from, to)
register Window w;
register SFDir *dir;
@@ -397,6 +400,7 @@ SFdrawStrings(w, dir, from, to)
}
}
+void
SFdrawList(n, doScroll)
int n;
int doScroll;
@@ -422,6 +426,7 @@ SFdrawList(n, doScroll)
}
}
+void
SFdrawLists(doScroll)
int doScroll;
{
@@ -432,7 +437,7 @@ SFdrawLists(doScroll)
}
}
-static
+static void
SFinvertEntry(n)
register int n;
{
Index: pixmap-2.6.6/SelFile/Path.c
===================================================================
--- pixmap-2.6.6.orig/SelFile/Path.c
+++ pixmap-2.6.6/SelFile/Path.c
@@ -83,7 +83,7 @@ SFchdir(path)
return result;
}
-static
+static void
SFfree(i)
int i;
{
@@ -106,7 +106,7 @@ SFfree(i)
dir->dir = NULL;
}
-static
+static void
SFstrdup(s1, s2)
char **s1;
char *s2;
@@ -114,7 +114,7 @@ SFstrdup(s1, s2)
*s1 = strcpy(XtMalloc((unsigned) (strlen(s2) + 1)), s2);
}
-static
+static void
SFunreadableDir(dir)
SFDir *dir;
{
@@ -129,7 +129,7 @@ SFunreadableDir(dir)
}
#ifdef SEL_FILE_IGNORE_CASE
-static
+static int
SFstrncmp(p, q, n)
register char *p, *q;
register int n;
@@ -173,7 +173,7 @@ SFstrncmp(p, q, n)
}
#endif /* def SEL_FILE_IGNORE_CASE */
-static
+static void
SFreplaceText(dir, str)
SFDir *dir;
char *str;
@@ -357,7 +357,7 @@ SFfindFile(dir, str)
return 0;
}
-static
+static void
SFunselect()
{
SFDir *dir;
@@ -377,7 +377,7 @@ SFcompareLogins(p, q)
return strcmp(p->name, q->name);
}
-static
+static void
SFgetHomeDirs()
{
struct passwd *pw;
@@ -484,6 +484,7 @@ SFfindHomeDir(begin, end)
return 0;
}
+void
SFupdatePath()
{
static int alloc;
@@ -673,6 +674,7 @@ SFupdatePath()
}
}
+void
SFsetText(path)
char *path;
{
Index: pixmap-2.6.6/SelFile/SFinternal.h
===================================================================
--- pixmap-2.6.6.orig/SelFile/SFinternal.h
+++ pixmap-2.6.6/SelFile/SFinternal.h
@@ -143,3 +143,13 @@ extern char SFstatChar();
extern XtIntervalId SFdirModTimerId;
extern int (*SFfunc)();
+
+extern void SFinitFont();
+extern void SFcreateGC();
+extern void SFdrawList(int n, int doScroll);
+extern void SFdrawLists(int doScroll);
+extern int SFchdir(char *path);
+extern void SFupdatePath();
+extern void SFsetText(char *path);
+extern void SFtextChanged();
+extern int SFgetDir(SFDir *dir);
Index: pixmap-2.6.6/SelFile/SelFile.c
===================================================================
--- pixmap-2.6.6.orig/SelFile/SelFile.c
+++ pixmap-2.6.6/SelFile/SelFile.c
@@ -150,7 +150,7 @@ SFexposeList(w, n, event, cont)
return;
}
- SFdrawList(n, SF_DO_NOT_SCROLL);
+ SFdrawList((int)n, SF_DO_NOT_SCROLL);
}
/* ARGSUSED */
@@ -600,6 +600,7 @@ SFopenFile(name, mode, prompt, failed)
return fp;
}
+void
SFtextChanged()
{
@@ -629,7 +630,7 @@ SFgetText()
SFtextBuffer);
}
-static
+static int
SFprepareToReturn()
{
SFstatus = SEL_FILE_NULL;
|