1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
override_dh_install:
find debian/tmp -name *.la -delete
find debian/tmp -name *.a -delete
mkdir -p debian/tmp/usr/share/metainfo/
mv debian/tmp/usr/share/appdata/* debian/tmp/usr/share/metainfo/
rmdir debian/tmp/usr/share/appdata/
dh_install
override_dh_missing:
dh_missing --fail-missing
override_dh_strip:
dh_strip -p libplank1 --dbgsym-migration='libplank1-dbg (<< 0.11.2-2~)'
dh_strip -p plank --dbgsym-migration='plank-dbg (<< 0.11.2-2~)'
override_dh_builddeb:
dh_builddeb -- -Zxz
override_dh_auto_configure:
dh_auto_configure -- \
--enable-headless-tests
override_dh_auto_test:
dh_auto_test || true
override_dh_makeshlibs:
dh_makeshlibs -p libplank1 -V 'libplank1 (>= 0.11.2)'
%:
dh $@
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|