1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64
|
Description: Use simde for wider portability
Author: Nilesh Patra <npatra974@gmail.com>
Forwarded: https://github.com/PLAST-software/plast-library/pull/8
Last-Update: 2020-12-06
@@ -19,15 +19,8 @@
#include <algo/hits/gap/SmallGapHitIteratorSSE8.hpp>
-#if __SSE3__
- #include <pmmintrin.h>
-#else
- #if __SSE2__
- #include <emmintrin.h>
- #else
- #warning error undefined __SSE3__ or __SSE2__
- #endif
-#endif
+#define SIMDE_ENABLE_NATIVE_ALIASES
+#include <simde/x86/sse3.h>
using namespace std;
using namespace misc;
@@ -21,15 +21,8 @@
#include <algo/hits/ungap/UngapHitIteratorSSE16.hpp>
-#if __SSE3__
- #include <pmmintrin.h>
-#else
-#if __SSE2__
- #include <emmintrin.h>
-#else
- #warning error undefined __SSE3__ or __SSE2__
-#endif
-#endif
+#define SIMDE_ENABLE_NATIVE_ALIASES
+#include <simde/x86/sse3.h>
using namespace std;
using namespace misc;
@@ -20,15 +20,8 @@
#include <algo/hits/ungap/UngapHitIteratorSSE8.hpp>
-#if __SSE3__
- #include <pmmintrin.h>
-#else
-#if __SSE2__
- #include <emmintrin.h>
-#else
- #warning error undefined __SSE3__ or __SSE2__
-#endif
-#endif
+#define SIMDE_ENABLE_NATIVE_ALIASES
+#include <simde/x86/sse3.h>
using namespace std;
using namespace misc;
|