File: changelog

package info (click to toggle)
pleiades 1.5.0-1
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 144,860 kB
  • ctags: 938
  • sloc: java: 7,163; xml: 1,361; sh: 52; makefile: 26
file content (275 lines) | stat: -rw-r--r-- 9,172 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
pleiades (1.5.0-1) unstable; urgency=medium

  * New upstream release
  * debian/control
    - set Standards-Version: 3.9.6
  * debian/patches
    - refresh patches
    - drop: bug713779_dont-specify-encoding-as-null.patch: merged upstream
  * debian/copyright
    - add copyright mention to some files that was previously removed from
      source tarball

 -- Hideki Yamane <henrich@debian.org>  Sun, 12 Oct 2014 02:38:27 +0900

pleiades (1.4.0-dfsg-6) unstable; urgency=medium

  * debian/control
    - add Vcs-* fields.
    - set Standards-Version: 3.9.5
    - set Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
      as Maintainer

 -- Hideki Yamane <henrich@debian.org>  Thu, 02 Jan 2014 19:07:55 +0900

pleiades (1.4.0-dfsg-5) unstable; urgency=low

  * update debian/po/ja.po, thanks to victory <victory.deb@gmail.com>
    (Closes: #717709)

 -- Hideki Yamane <henrich@debian.org>  Mon, 30 Sep 2013 15:32:44 +0900

pleiades (1.4.0-dfsg-4) unstable; urgency=medium

  * debian/control
    - revert to "Depends: libcommons-lang-java", not lang3

 -- Hideki Yamane <henrich@debian.org>  Tue, 02 Jul 2013 20:00:56 +0900

pleiades (1.4.0-dfsg-3) unstable; urgency=medium

  * debian/control
    - set "Build-Depends-Indep: libcommons-lang3-java"
  * debian/patches
    - add use_org.apache.commons.lang3.patch, due to above changes
    - update build.xml to use above libcommons-lang3-java library
    - add bug713779_dont-specify-encoding-as-null.patch (Closes: #713779)

 -- Hideki Yamane <henrich@debian.org>  Tue, 25 Jun 2013 18:40:44 +0900

pleiades (1.4.0-dfsg-2) unstable; urgency=low

  * upload to unstable
  * debian/rules,watch
    - add get-orig-source target

 -- Hideki Yamane <henrich@debian.org>  Sun, 07 Apr 2013 07:44:23 +0900

pleiades (1.4.0-dfsg-1) experimental; urgency=low

  * New upstream release
  * debian/patches
    - drop fix-config.ini since it is unnecessary by change in upstream
    - add compile_junit.patch
  * debian/control
    - set Standards-Version: 3.9.4
    - add Build-Depends: ant-optional (/usr/share/ant/lib/ant-junit.jar),
      junit
  * debian/rules
    - deal with changes in build.xml

 -- Hideki Yamane <henrich@debian.org>  Tue, 05 Mar 2013 23:47:08 +0900

pleiades (1.3.4-dfsg-4) unstable; urgency=low

  * upload to unstable 

 -- Hideki Yamane <henrich@debian.org>  Mon, 06 Aug 2012 23:44:28 +0900

pleiades (1.3.4-dfsg-3) experimental; urgency=low

  * debconf/po
    - add Portuguese translation (Closes: #678739)
  * temporary disabled debconf usage, its behaivior violates policy and I'll 
    look for another solution after Wheezy will be released (Closes: #679846)

 -- Hideki Yamane <henrich@debian.org>  Mon, 06 Aug 2012 18:29:33 +0900

pleiades (1.3.4-dfsg-2) experimental; urgency=low

  [ Christian Perrier ]
  * Debconf templates and debian/control reviewed by the debian-l10n-
    english team as part of the Smith review project. Closes: #676312
  * [Debconf translation updates]
  * Swedish (Martin Bagge / brother).  Closes: #678321
  * Danish (Joe Hansen).  Closes: #678323
  * Slovak (Ivan Masár).  Closes: #678334
  * Russian (Yuri Kozlov).  Closes: #678432
  * Galician (Jorge Barreiro).  Closes: #678465
  * Czech (Michal Simunek).  Closes: #678672
  * French (Étienne Gilli).  Closes: #679006
  * Polish (Michał Kułach).  Closes: #679434
  * German (Chris Leick).  Closes: #679461
  * Spanish; (# traductor (campo Last-Translator) y ponga en copia a la
    lista de Fernando C. Estrada).  Closes: #679805
  * Italian (Beatrice Torracca).  Closes: #680569

  [ Hideki Yamane ]
  * debian/control
    - set "Build-Depends: debhelper (>= 9)"
  * upload to experimental

 -- Hideki Yamane <henrich@debian.org>  Sat, 04 Aug 2012 10:28:49 +0900

pleiades (1.3.4-dfsg-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - improve descriptions
    - bump up debehelper version to use xz option
  * debian/compat
    - set 9
  * add debian/NEWS file about automatic configuration and manual
    configuration due to upgrading eclipse package would override its change
  * debian/patches
    - refresh all patches to meet to DEP3 format.
  * debian/watch
    - update to catch newer upstream version correctly.
  * debian/rules
    - add "--parallel" option to build
    - remove unnecessary lib directory with dh_auto_install
  * debian/copyright
    - update to deal with changes about not exclude javaassist and commons-io
      from upstream source

 -- Hideki Yamane <henrich@debian.org>  Sun, 01 Jul 2012 10:03:06 +0900

pleiades (1.3.4~I20120531-dfsg-2) unstable; urgency=low

  * debian/control
    - add "Depends: dpkg (>= 1.15.6~)" to deal with Lintian warning
      "data.tar.xz-member-without-dpkg-pre-depends"
  * debian/copyright
    - update "Format:" field to
      http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
      and set License: EPL-1.0
  * debian/rules
    - install readme_pleiades_changes.txt as upstream ChangeLog

 -- Hideki Yamane <henrich@debian.org>  Tue, 05 Jun 2012 13:07:59 +0900

pleiades (1.3.4~I20120531-dfsg-1) unstable; urgency=low

  * New upstream snapshot
  * debian/pleiades.{templates,config}
    - add it to enable debconf
  * debian/control
    - add "Build-Depends: po-debconf", "Pre-Depends: debconf"
  * debian/rules
    - add option to xz to compress it more efficiently.
    - exec debconf-updatepo via dh_clean
  * debian/pleiades.{postinst,postrm}
    - enable automatic configuration
  * debian/patches
    - build.xml: refresh it.
    - add disable-create-src_zip to reduce build time.
  * remove debian/README.Debian
  * debian/copyright
    - update my address

 -- Hideki Yamane <henrich@debian.org>  Mon, 04 Jun 2012 10:24:02 +0900

pleiades (1.3.3-dfsg-3) unstable; urgency=low

  * debian/control
    - set "Standards-Version: 3.9.3"
  * debian/rules
    - compress with xz
  * debian/patches
    - build.xml: fix "missing-classpath" (Lintian).

 -- Hideki Yamane <henrich@debian.org>  Tue, 29 May 2012 09:42:09 +0900

pleiades (1.3.3-dfsg-2) unstable; urgency=low

  * debian/control
    - remove unnecessary "DM-Upload-Allowed: yes" field

 -- Hideki Yamane <henrich@debian.org>  Sat, 17 Sep 2011 10:11:42 +0900

pleiades (1.3.3-dfsg-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - set "Standards-Version: 3.9.2" 
  * debian/patches
    - adjust build.xml and fix-config.ini 

 -- Hideki Yamane <henrich@debian.org>  Thu, 08 Sep 2011 23:45:14 +0900

pleiades (1.3.2-dfsg-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - change my email address
    - Build-Depends: debhelper (>= 7.0.50~)
    - set "Standards-Version: 3.9.1" 
  * debian/watch
    - fix to work
  * debian/patches
    - refresh fix-config.ini
    - refresh build.xml, most of non-debian specific changes were included
      in upstream
  * debian/rules
    - change ant target from build-full to build.full

 -- Hideki Yamane <henrich@debian.org>  Sun, 31 Oct 2010 21:09:27 +0900

pleiades (1.3.1-dfsg-1) unstable; urgency=low

  * Upload to Debian (Closes: #555846)
  * remove lib directory to comply DFSG
  * also remove srctest/jp/sourceforge/mergedoc/pleiades/resource/3.* since
    those files' license is not clear enough and not need to build.
  * remove debian/eclipserc,pleiades.examples since eclipse no longer uses
    .eclipserc and update debian/README.Debian
  * add debian/patches/build.xml and use "source format 3.0 (quilt)" 
  * add debian/pleiades.links and put files to /usr/share/eclipse
  * remove debian/{pleiades.install,lintian/*}
  * add debian/patches/fix-config.ini to deal with error with finding 
    config.ini
  * debian/control
    - set "DM-Upload-Allowed: yes"
    - correction
      + "Build-Depends: default-jdk"
      + add "Depends: libcommons-lang-java, libcommons-io-java, 
        libjavassist-java"
      + remove "Recommends: default-jre-headless"
    Thanks to Niels Thykier <niels@thykier.net> and Matthew Johnson 
    <mjj29@debian.org>!

 -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Mon, 22 Mar 2010 15:05:28 +0900

pleiades (1.3.1-1~pre5) unstable; urgency=low

  * put features file to /usr/lib 

 -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sun, 21 Mar 2010 17:35:26 +0900

pleiades (1.3.1-1~pre4) unstable; urgency=low

  * debian/control
    - move default-jre-headless from Depends to Recommends 

 -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sun, 15 Nov 2009 19:35:40 +0900

pleiades (1.3.1-1~pre3) unstable; urgency=low

  * debian/control
    - add "Depends: default-jre-headless" 

 -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sun, 15 Nov 2009 09:20:07 +0900

pleiades (1.3.1-1~pre2) unstable; urgency=low

  * debian/README.Debian
    - $ cp /usr/share/"doc"/pleiades/examples/eclipserc ~/.eclipse/eclipserc
      Thanks to Wataru Nakanishi <watayan@meigaku.ac.jp>

 -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Sat, 14 Nov 2009 15:23:53 +0900

pleiades (1.3.1-1~pre) unstable; urgency=low

  * Initial release at sourceforge.jp (not Debian Official, yet)

 -- Hideki Yamane (Debian-JP) <henrich@debian.or.jp>  Thu, 12 Nov 2009 11:57:55 +0900