1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
Description: debianization
Meant to maintain a minimal debian/rules, to fix warnings,
to address Debian specific stuff in general.
This patch actually specifies the Python interpreter for cmake and
in the shebang of the Python test.
Origin: debian
Forwarded: not-needed
Author: Jerome Benoit <calculus@rezozer.net>
Last-Update: 2021-11-16
@@ -55,8 +55,8 @@
# Check whether we have SWIG and the Python libraries installed
find_package(SWIG REQUIRED)
include(${SWIG_USE_FILE})
- find_package(PythonInterp REQUIRED)
- find_package(PythonLibs REQUIRED)
+ find_package(PythonInterp 3 REQUIRED)
+ find_package(PythonLibs 3 REQUIRED)
include_directories(${PYTHON_INCLUDE_PATH})
# using distutils.
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
from __future__ import print_function
|