File: changelog

package info (click to toggle)
plowshare 2.1.7-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 732 kB
  • sloc: sh: 5,039; makefile: 90; sed: 13
file content (205 lines) | stat: -rw-r--r-- 7,599 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
plowshare (2.1.7-4) unstable; urgency=medium

  * Use debhelper-compat instead of debian/compat
  * Drop the transitional plowshare4 package and associated Break/Replace
    (Closes: #940756).
  * Update Standards-Version to 4.4.1 (no changes).
  * Remove the default module URL (Closes: #927841).
  * Disable source minification script.

 -- Carl Suster <carl@contraflo.ws>  Tue, 12 Nov 2019 22:35:35 +1100

plowshare (2.1.7-3) unstable; urgency=medium

  * Assist with re-enabling javascript support (Closes: #909655)
    - Suggest rhino as JS interpreter.
    - Add a section to README.Debian explaining how to configure JS.
  * Rename debian/README => debian/README.Debian so it's installed properly.
  * Remove references to the defunct plowshare-modules package.
  * Update Standards-Version to 4.3.0 (no changes).

 -- Carl Suster <carl@contraflo.ws>  Sat, 20 Apr 2019 15:36:52 +1000

plowshare (2.1.7-2) unstable; urgency=medium

  * Update VCS to point to Salsa.
  * Correct typo in patch description.
  * Update debhelper compat to 11 (no changes).
  * Update to standards version 4.2.0:
    - use HTTPS URL in changelog.
  * Set Rules-Requires-Root to no.
  * De-emphasise plowshare-modules in favour of plowmod:
    - drop from Recommends to Suggests and
    - promote git from Suggests to Recommends since the plowmod script
      that replaces the modules package requires git.

 -- Carl Suster <carl@contraflo.ws>  Tue, 14 Aug 2018 10:54:27 +1000

plowshare (2.1.7-1) unstable; urgency=medium

  * New upstream release.
  * Bump upstream and debian/* copyright year.
  * Change VCS from GitHub to GitLab.
  * Bump standards version to 4.1.1, no changes.
  * Switch gbp config for sbuild.
  * Remove Priority: extra from the transitional package.
  * Include pkg-info.mk instead of parsing changelog to get upstream version.

 -- Carl Suster <carl@contraflo.ws>  Fri, 24 Nov 2017 16:53:50 +1100

plowshare (2.1.6-1) unstable; urgency=medium

  * New upstream release.
  * patches/01-disable-javascipt:
    - allow javascript to be enabled again by setting an environment variable.

 -- Carl Suster <carl@contraflo.ws>  Fri, 09 Dec 2016 11:47:02 +1100

plowshare (2.1.5-1) unstable; urgency=medium

  * New upstream release.
  * debian/rules:
    - use the new upstream shell script 'minifier' (a simple sed script).
  * debian/control:
    - bump standards version to 3.9.8 - no changes needed.

 -- Carl Suster <carl@contraflo.ws>  Wed, 22 Jun 2016 12:07:23 +1000

plowshare (2.1.3-1) unstable; urgency=medium

  * New upstream release.
  * debian/control:
    - slightly improve the long description.
    - bump to standards version 3.9.7 - no changes needed.
    - update Vcs-Git to use HTTPS.
  * debian/copyright: update copyright years to reflect upstream.
  * debian/patches/*:
    - refresh patches.
    - drop 02-src-spelling.patch - applied upstream.
  * Minor packaging workflow update:
    - debian/get-version: update to use gbp branch layout.
    - debian/gbp.conf: use a separate build directory.
    - debian/source/local-options: no longer need to unapply patches.

 -- Carl Suster <carl@contraflo.ws>  Wed, 13 Apr 2016 17:08:19 +1000

plowshare (2.1.2-1) unstable; urgency=medium

  * New upstream releases.
    - debian/NEWS: note support for user modules.
    - debian/NEWS, debian/README: note the new plowmod tool.
    - debian/rules: install new upstream changelog.
    - debian/plowshare.links, debian/plowshare.manpages: add plowmod.
    - debian/plowshare.docs: README -> README.md.
    - debian/control: suggest git for use with plowmod.

  * debian/gbp.conf, debian/get-version, debian/rules:
    - Remove dependency on git history from the build process.

  * debian/control:
    - Change capitalisation of short description.

  * debian/plowshare.completion, debian/rules:
    - Install completion for each command.

  * debian/plowshare.links, debian/plowshare.manpages: sort alphabetically.

  * debian/plowshare.install:
    - No longer install dummy module config file (Closes: #801815).

  * debian/rules:
    - Trap errors in shell script loops.

  * debian/gbp.conf, debian/patches/*, debian/source/local-options:
    - Re-export patches using gbp pq without changes and adapt config.

  * debian/patches/02-src-spelling.patch:
    - Fix some typos in upstream manpages.

 -- Carl Suster <carl@contraflo.ws>  Wed, 14 Oct 2015 15:33:28 +0200

plowshare (2.0.1-1) unstable; urgency=medium

  * New upstream release.
    - Removed patches applied upstream (Closes: #780311)

  * Upload to unstable

  * The modules are now split into a separate package plowshare-modules
    - Upstream no longer officially maintains the modules
    - Now just the framework lives in this package
    - Remove the modules which now live in the new package plowshare-modules
    - debian/copyright: remove references to removed files
    - debian/copyright: new upstream location
    - debian/upstream/metadata: new upstream location
    - debian/watch: new upstream location
    - debian/control: new upstream homepage
    - debian/control: explain the separation of code in the description
    - debian/control: recommend the new modules package
    - debian/NEWS: announce the restructuring

  * Rename plowshare4 -> plowshare source and binary to reflect new name
    - debian/control: transitional package to handle the rename
    - debian/copyright: update upstream name

  * debian/rules:
    - Use new bash completion path (Closes: #798806)

 -- Carl Suster <carl@contraflo.ws>  Sat, 26 Sep 2015 14:32:31 +0200

plowshare4 (1.0.5-2) unstable; urgency=high

  * Disable javascript support (Closes: #791467)

 -- Carl Suster <carl@contraflo.ws>  Tue, 14 Jul 2015 18:45:22 +1000

plowshare4 (1.2.0-1) experimental; urgency=medium

  * New upstream release.
  * spelling.patch:
    - Corrects some new spelling errors
  * shellcheck.patch:
    - Addresses some warnings from shellcheck
  * debian/supported_sites:
    - Outputs list of sites for copying into debian/control
  * debian/copyright:
    - Update packaging and default copyright to include 2015
  * debian/control:
    - List supported sites using above script rather than manually
    - Update long description to highlight existing features

 -- Carl Suster <carl@contraflo.ws>  Sat, 24 Jan 2015 20:00:00 +1100

plowshare4 (1.0.6-1) experimental; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.6, no changes.
  * Point Vcs-Git field to the correct branch.
  * Improve the derivation of the version string from git.
  * Update list of supported modules.
  * Remove Depends: bash (bash >=4.1 is present and essential in debian).
  * Add watch file using fakeupstream.cgi script.
  * spelling_comments.patch: corrects typos in comments
  * spelling_helpfull_flag.patch: corrects typo in CLI option.
  * utf8.patch: repairs an encoding issue.
  * Add upstream metadata.

 -- Carl Suster <carl@contraflo.ws>  Mon, 27 Oct 2014 21:52:42 +1100

plowshare4 (1.0.5-1) unstable; urgency=medium

  * New upstream release.
  * fix-man-page-typos.patch now fixed in upstream.
  * Drop Replaces: plowshare since it was never in the archive.
  * Drop Conflicts: plowshare3 since it was never in the archive.
  * Add Recommends: sxiv as an alternative X image viewer.
  * Add Suggests: fbi as a framebuffer viewer.
  * Remove executable permission on module files.

 -- Carl Suster <carl@contraflo.ws>  Sun, 31 Aug 2014 18:53:00 +1000

plowshare4 (1.0.4-1) unstable; urgency=low

  * Initial release. (Closes: #599924)

 -- Carl Suster <carl@contraflo.ws>  Sat, 26 Jul 2014 16:38:56 +1000