1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
|
export PYBUILD_NAME=pox
export PYBUILD_TEST_CUSTOM=1
export PYBUILD_TEST_ARGS={interpreter} -m pox.tests
%:
dh $@ --with sphinxdoc --buildsystem=pybuild
override_dh_auto_test:
ifeq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
execute_after_dh_auto_build:
PYTHONPATH=$(CURDIR) $(MAKE) -C docs SPHINXBUILD=sphinx-build html
execute_after_dh_auto_clean:
$(MAKE) -C docs SPHINXBUILD=sphinx-build clean
override_dh_installdocs:
dh_installdocs -ppython-pox-doc --doc-main-package=python3-pox
dh_installdocs --remaining-packages
mv debian/python-pox-doc/usr/share/doc/python3-pox/build debian/python-pox-doc/usr/share/doc/python3-pox/html
endif
|