1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
|
Description: Fix ocaml build issue
Bug-Debian: https://bugs.debian.org/1002230
Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1002230#19
Author: Stéphane Glondu <glondu@debian.org>
Last-Update: Wed, 22 Dec 2021 09:39:59 +0100
@@ -544,7 +544,7 @@ let collapse_marks gt mass markm =
|> snd |> List.tl |> List.rev)
markm
-let map_min f l = List.map f l |> List.min
+let map_min f l = List.map f l |> (fun x -> List.min x)
let map_reduce f_map f_reduce l = List.map f_map l |> List.reduce f_reduce
(* combine across the solutions below an internal node, given a solution list
|