File: META.ab

package info (click to toggle)
ppx-type-conv 113.33.03-1
  • links: PTS, VCS
  • area: main
  • in suites: sid, stretch
  • size: 400 kB
  • ctags: 447
  • sloc: ml: 6,649; makefile: 56
file content (18 lines) | stat: -rw-r--r-- 804 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
version = "$(pkg_version)"
description = "Support Library for type-driven code generators"
requires = "ppx_core ppx_driver"
archive(byte  ) = "ppx_type_conv.cma"
archive(native) = "ppx_type_conv.cmxa"
plugin(byte  ) = "ppx_type_conv.cma"
plugin(native) = "ppx_type_conv.cmxs"
exists_if = "ppx_type_conv.cma"

# Until this is released: https://github.com/whitequark/ppx_deriving/pull/95
package "for_ppx_deriving" (
  description = "Don't use this directly"
  error(ppx_driver) = "Cannot use ppx_type_conv.for_ppx_deriving when ppx_driver is set"
  requires = "ppx_core.for_ppx_deriving ppx_deriving ppx_driver.for_ppx_deriving"
  exists_if = "ppx_type_conv.cma"
  ppxopt(-custom_ppx) = "ppx_deriving,./ppx_type_conv.cma"
  ppxopt(-ppx_driver,-custom_ppx) += "ppx_deriving,./ppx_type_conv_deriving.cma"
)