File: rules

package info (click to toggle)
presage 0.9.1-2.1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid, stretch
  • size: 11,572 kB
  • ctags: 11,922
  • sloc: cpp: 86,282; sh: 11,775; ansic: 4,043; python: 1,218; makefile: 1,043; cs: 1,009; xml: 57
file content (45 lines) | stat: -rwxr-xr-x 1,510 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#!/usr/bin/make -f

#export DH_VERBOSE=1

PYVERS=$(shell pyversions -vs)

%:
	dh $@ --with autoreconf --with python2


# Enable build hardening
#
override_dh_auto_configure:
	dh_auto_configure -- $(shell dpkg-buildflags --export=configure)

# Ensure dbus python build is cleaned out
#
override_dh_auto_clean:
	dh_auto_clean
	rm -rf apps/dbus/build

# Override needed to:
# - fix embedded-javascript-library lintian warning
# - install into python-presage and pyprompter for each supported python version
#
override_dh_auto_install:	
	dh_auto_install
	set -e; if test -f debian/tmp/usr/share/presage/html/jquery.js; \
	then \
		rm -f debian/tmp/usr/share/presage/html/jquery.js; \
		ln -s /usr/share/javascript/jquery/jquery.js debian/tmp/usr/share/presage/html/jquery.js; \
	fi
	set -e; for i in $(PYVERS); do \
		(cd bindings/python && $(shell dpkg-buildflags --export=configure) python$$i setup.py install --root $(CURDIR)/debian/python-presage --prefix usr --install-layout=deb); \
		(cd apps/python && python$$i setup.py install --root $(CURDIR)/debian/pyprompter --prefix usr --install-layout=deb); \
		(cd apps/dbus && python$$i setup.py install --root $(CURDIR)/debian/presage-dbus --prefix usr --install-layout=deb); \
	done

# Override needed to create debug packages
#
override_dh_strip:
	dh_strip -plibpresage1v5 --dbg-package=libpresage1-dbg
	dh_strip -ppresage --dbg-package=presage-dbg
	dh_strip -pgprompter --dbg-package=gprompter-dbg
	dh_strip -ppython-presage --dbg-package=python-presage-dbg