1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
Description: Fix test failure with Numpy 1.24.
Author: Bas Couwenberg <sebastic@debian.org>
Bug-Debian: https://bugs.debian.org/1027233
@@ -158,9 +158,9 @@ def fetchPDBLigand(cci, filename=None):
resnums = np.ones(n_atoms, dtype=ATOMIC_FIELDS['charge'].dtype)
alternate_atomnames = np.zeros(n_atoms, dtype=ATOMIC_FIELDS['name'].dtype)
- leaving_atom_flags = np.zeros(n_atoms, np.bool)
- aromatic_flags = np.zeros(n_atoms, np.bool)
- stereo_configs = np.zeros(n_atoms, np.bool)
+ leaving_atom_flags = np.zeros(n_atoms, bool)
+ aromatic_flags = np.zeros(n_atoms, bool)
+ stereo_configs = np.zeros(n_atoms, bool)
ordinals = np.zeros(n_atoms, int)
name2index = {}
|