1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
include /usr/share/dpkg/pkg-info.mk
export DH_VERBOSE=1
BINNAME := prometheus-squid-exporter
BUILDDIR := $(CURDIR)/build
METAPKG := github.com/prometheus/common
BRANCH := debian/sid
USER := pkg-go-maintainers@lists.alioth.debian.org
BUILD_DATE := $(shell date --utc --date='@$(SOURCE_DATE_EPOCH)' \
+%Y%m%d-%H:%M:%S)
GO_VERSION := $(shell go version | sed 's/go version \(\S*\).*/\1/')
BUILDTAGS :=
BUILDFLAGS = -tags "$(BUILDTAGS)" -ldflags \
" -X $(METAPKG)/version.Version=$(DEB_VERSION_UPSTREAM)\
-X $(METAPKG)/version.Revision=$(DEB_VERSION)\
-X $(METAPKG)/version.Branch=$(BRANCH)\
-X $(METAPKG)/version.BuildUser=$(USER)\
-X $(METAPKG)/version.BuildDate=$(BUILD_DATE)\
-X $(METAPKG)/version.GoVersion=$(GO_VERSION)"
%:
dh $@ --buildsystem=golang --with=golang --builddirectory=$(BUILDDIR)
override_dh_auto_build:
dh_auto_build -- $(BUILDFLAGS)
mv -v $(BUILDDIR)/bin/squid-exporter $(BUILDDIR)/bin/$(BINNAME)
override_dh_auto_install:
dh_auto_install -- --no-source
override_dh_installinit:
dh_installinit --noscripts
|