File: setup.cfg

package info (click to toggle)
psychopy 2020.2.10%2Bdfsg-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 44,056 kB
  • sloc: python: 119,649; javascript: 3,022; makefile: 148; sh: 125; xml: 9
file content (99 lines) | stat: -rw-r--r-- 2,596 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
[bdist_wheel]
universal = 1

[metadata]
license_file = LICENSE
license = GNU GPLv3 (or more recent equivalent)
author = Jonathan Peirce
author_email = jon.peirce@gmail.com
maintainer_email = jon.peirce@gmail.com
url = http://www.psychopy.org/
download_url = https://github.com/psychopy/psychopy/releases/
description = Psychology experiment software in Python
long_description = file: README.md
long_description_content_type = text/markdown
classifiers =
    Development Status :: 4 - Beta
    Operating System :: MacOS :: MacOS X
    Operating System :: Microsoft :: Windows
    Operating System :: POSIX :: Linux
    Programming Language :: Python :: 2
    Programming Language :: Python :: 2.7
    Programming Language :: Python :: 3
    Programming Language :: Python :: 3.6
    Programming Language :: Python :: 3.7

[options]
python_requires = >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, !=3.5.*
setup_requires = 
    distro; platform_system == "Linux"
install_requires =
    requests[security]
    numpy
    scipy
    matplotlib
    pandas
    pillow
    glfw
    pyopengl
    soundfile
    sounddevice
    python-bidi
    arabic_reshaper
    future
    json_tricks
    pyosf
    xlrd
    openpyxl
    pyserial
    pyyaml
    gevent
    msgpack
    msgpack-numpy
    psutil
    tables
    pyzmq
    moviepy
    opencv-python
    python-gitlab
    gitpython
    astunparse
    esprima
    freetype-py
    jedi >= 0.15.2
    # Platform-specific dependencies.
    javascripthon; python_version >= "3.5"
    pyglet >= 1.3; python_version < "3.8"
    pyglet >= 1.3.3; python_version >= "3.8"
    pathlib; python_version < "3.4"
    questplus >= 2019.3; python_version >= "3.6"
    imageio < 2.5; python_version < "3"
    imageio >= 2.5; python_version >= "3"
    imageio-ffmpeg; python_version >= "3"
    pyparallel; platform_system == "Linux"
    pyWinhook; platform_system == "Windows"
    pyqmix >= 2018.12.13; platform_system == "Windows"
    pyqt5; python_version >= "3"
    wxPython != 4.0.2, != 4.0.3; platform_system != "Linux"
    pypiwin32; platform_system == "Windows"
    pyobjc-core; platform_system == "Darwin"
    pyobjc-framework-Quartz; platform_system == "Darwin"
    distro; platform_system == "Linux"
    websocket_client

[options.entry_points]
gui_scripts =
    psychopy = psychopy.app.psychopyApp:main

[versioneer]
VCS = git
style = pep440
versionfile_source = psychopy/_version.py
versionfile_build =
tag_prefix = ''

[tool:pytest]
markers =
    needs_sound: requires sound hw, thus should not be excercised e.g. on travis-ci
    needs_pygame: requires pygame