File: control

package info (click to toggle)
puppet-lint 2.3.6-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 928 kB
  • sloc: ruby: 9,051; sh: 395; makefile: 2
file content (25 lines) | stat: -rw-r--r-- 1,047 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Source: puppet-lint
Section: admin
Priority: optional
Maintainer: Puppet Package Maintainers <pkg-puppet-devel@lists.alioth.debian.org>
Uploaders: Stig Sandbeck Mathisen <ssm@debian.org>,
           Micah Anderson <micah@debian.org>,
           Apollon Oikonomopoulos <apoikos@debian.org>
Build-Depends: debhelper (>= 11), gem2deb (>= 0.2.9~), ruby-rspec-its, ruby-rspec-collection-matchers, ruby-simplecov
Standards-Version: 4.3.0
Vcs-Git: https://salsa.debian.org/puppet-team/puppet-lint.git
Vcs-Browser: https://salsa.debian.org/puppet-team/puppet-lint
Homepage: https://github.com/rodjek/puppet-lint/
XS-Ruby-Versions: all

Package: puppet-lint
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
Depends: ${shlibs:Depends}, ${misc:Depends}, ruby | ruby-interpreter
Suggests: rake
Description: check puppet manifests for style guide conformity
 Checks your Puppet manifests against the Puppet Labs style guide and
 alerts you to any discrepancies.
 .
 This program checks spacing, indentation, whitespace, quoting,
 conditionals and classes.