File: puppet-lint.gemspec

package info (click to toggle)
puppet-lint 2.3.6-1
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 928 kB
  • sloc: ruby: 9,051; sh: 395; makefile: 2
file content (19 lines) | stat: -rw-r--r-- 668 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
$LOAD_PATH.push(File.expand_path('../lib', __FILE__))
require 'puppet-lint/version'

Gem::Specification.new do |s|
  s.name = 'puppet-lint'
  s.version = PuppetLint::VERSION.dup
  s.homepage = 'https://github.com/rodjek/puppet-lint/'
  s.summary = 'Ensure your Puppet manifests conform with the Puppetlabs style guide'
  s.description = 'Checks your Puppet manifests against the Puppetlabs
  style guide and alerts you to any discrepancies.'

  s.files = Dir.glob('**/*')
  s.test_files = Dir.glob('spec/**/*')
  s.executables = Dir.glob('bin/*').map{ |f| File.basename(f) }
  s.require_paths = ['lib']

  s.authors = ['Tim Sharpe']
  s.email = 'tim@sharpe.id.au'
end