File: README.md

package info (click to toggle)
puppet-module-asciiduck-sssd 0.3.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 168 kB
  • sloc: ruby: 423; sh: 28; makefile: 2
file content (39 lines) | stat: -rw-r--r-- 1,177 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
# sssd

#### Table of Contents

1. [Overview](#overview)
2. [Module Description](#module-description)
3. [Usage - Configuration options and additional functionality](#usage)
4. [Development - Guide for contributing to the module](#development)

## Overview

SSSD is the replacement for nslcd that is the default in CentOS and RHEL 7.


## Module Description

This module will install, configure and manage the SSSD service, but it will
not touch your nsswitch or your pam configs, that's the job for another module.

Currently this module only supports RHEL/CentOS 7, Ubuntu 14.04, Debian 8.x; however, 
if you specify the needed parameters yourself you can override the "unsupported 
os" failure.

Previously this module would install the sudo package on Debian based platforms which
replaced the package sudo-ldap. It was decided that the decision of which sudo package
to use was out of scope of this module. If you are seeing issues with sudo and sssd 
on Ubuntu 14.04 or Debian 8.x ensure you have sudo installed and not sudo-ldap.

## Usage

Incoming


## Development

If you would like to contribute, just go through the standard:
* Fork
* Feature branch
* Pull Request