File: .travis.yml

package info (click to toggle)
puppet-module-ceilometer 16.3.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 868 kB
  • sloc: ruby: 1,690; python: 36; sh: 15; makefile: 11
file content (28 lines) | stat: -rw-r--r-- 787 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
language: ruby
bundler_args: --without development
before_script:
  - echo $PUPPET_GEM_VERSION | grep '2.6' && git clone git://github.com/puppetlabs/puppetlabs-create_resources.git spec/fixtures/modules/create_resources || true
script: "bundle exec rake spec SPEC_OPTS='--format documentation'"
rvm:
  - 1.8.7
  - 1.9.3
  - ruby-head
env:
  - PUPPET_GEM_VERSION="~> 2.6"
  - PUPPET_GEM_VERSION="~> 2.7"
  - PUPPET_GEM_VERSION="~> 3.0"
  - PUPPET_GEM_VERSION="~> 3.1"
matrix:
  allow_failures:
    - rvm: ruby-head
  exclude:
    - rvm: 1.9.3
      env: PUPPET_GEM_VERSION="~> 2.7"
    - rvm: ruby-head
      env: PUPPET_GEM_VERSION="~> 2.7"
    - rvm: 1.9.3
      env: PUPPET_GEM_VERSION="~> 2.6"
    - rvm: ruby-head
      env: PUPPET_GEM_VERSION="~> 2.6"
notifications:
  email: false