File: .rubocop.yml

package info (click to toggle)
puppet-module-puppet-community-mcollective 0.6.2-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 600 kB
  • sloc: ruby: 1,301; sh: 15; makefile: 15
file content (52 lines) | stat: -rw-r--r-- 1,032 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
AllCops:
  Exclude:
    - vendor/**/*
    - pkg/**/*
    - spec/fixtures/**/*
    - files/**/*

# Configuration parameters: AllowURI, URISchemes.
Metrics/LineLength:
  Max: 328

# 'Complexity' is very relative
Metrics/PerceivedComplexity:
  Enabled: false

# 'Complexity' is very relative
Metrics/CyclomaticComplexity:
  Enabled: false

# 'Complexity' is very relative
Metrics/AbcSize:
  Enabled: false

# Method length is not necessarily an indicator of code quality
Metrics/MethodLength:
  Enabled: false

# Class length is not necessarily an indicator of code quality
Metrics/ClassLength:
  Enabled: false

# dealbreaker:
Style/TrailingComma:
  Enabled: false
Style/ClosingParenthesisIndentation:
  Enabled: false

# we still support ruby 1.8
Style/HashSyntax:
  Enabled: false

Lint/AmbiguousRegexpLiteral:
  Enabled: true
Style/RegexpLiteral:
  Enabled: true
Style/WordArray:
  Enabled: true

# this catches the cases of using `module` for parser functions, types, or
# providers
Style/ClassAndModuleChildren:
  Enabled: false