File: metadata.json

package info (click to toggle)
puppet-module-puppetlabs-postgresql 5.4.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 980 kB
  • sloc: ruby: 5,047; sh: 52; makefile: 2
file content (82 lines) | stat: -rw-r--r-- 1,786 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
{
  "name": "puppetlabs-postgresql",
  "version": "5.4.0",
  "author": "Inkling/Puppet Labs",
  "summary": "Offers support for basic management of PostgreSQL databases.",
  "license": "Apache-2.0",
  "source": "git://github.com/puppetlabs/puppetlabs-postgresql.git",
  "project_page": "https://github.com/puppetlabs/puppetlabs-postgresql",
  "issues_url": "https://tickets.puppetlabs.com/browse/MODULES",
  "dependencies": [
    {
      "name": "puppetlabs/stdlib",
      "version_requirement": ">= 4.13.1 < 5.0.0"
    },
    {
      "name": "puppetlabs/apt",
      "version_requirement": ">= 2.0.0 < 5.0.0"
    },
    {
      "name": "puppetlabs/concat",
      "version_requirement": ">= 1.1.0 < 5.0.0"
    }
  ],
  "data_provider": null,
  "operatingsystem_support": [
    {
      "operatingsystem": "RedHat",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "CentOS",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "OracleLinux",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "Scientific",
      "operatingsystemrelease": [
        "5",
        "6",
        "7"
      ]
    },
    {
      "operatingsystem": "Debian",
      "operatingsystemrelease": [
        "7",
        "8"
      ]
    },
    {
      "operatingsystem": "Ubuntu",
      "operatingsystemrelease": [
        "14.04",
        "16.04"
      ]
    }
  ],
  "requirements": [
    {
      "name": "puppet",
      "version_requirement": ">= 4.7.0 < 6.0.0"
    }
  ],
  "pdk-version": "1.4.1",
  "template-url": "file:///opt/puppetlabs/pdk/share/cache/pdk-templates.git",
  "template-ref": "1.4.1-0-g52adbbb"
}